# Cpu traps / segfault

**URL:** <https://community.netdata.cloud/t/cpu-traps-segfault/1418>\
**Category:** Help\
**Tags:** agent\
**Created:** [June 10, 2021, 8:02am UTC](https://community.netdata.cloud/t/cpu-traps-segfault/1418 "2021-06-10T08:02:28Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![sdo](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/sdo/32/360_2.png) [@sdo](https://community.netdata.cloud/u/sdo)\
**Post date:** [June 10, 2021, 8:02am UTC](https://community.netdata.cloud/t/cpu-traps-segfault/1418/1 "2021-06-10T08:02:28Z")

</div>

Since a few days ago our central netdata metrics collector have started to cause cpu traps. It runs as a docker container.

The host syslog error message is:

Jun 9 06:29:59 netdata01 kernel: [156866.969743] traps: WEB\_SERVER[stat[24373] general protection ip:7fe2b2ff22d9 sp:7fe2b03c8878 error:0 in ld-musl-x86\_64.so.1[7fe2b2feb000+47000]

The error happens approximately every 7 minute. Sometimes every 1 min. And sometimes as long as 12 minutes in between crashed.

I have tried version 1.26.0, 1.30.1 and 1.31.0 and each have precisely same error.

When running as a native systemd application directly on host Ubuntu, the error message in syslog is:

Jun 10 08:53:54 netdata01 kernel: [62290.509176] WEB\_SERVER[stat[23533]: segfault at 55570589ba34 ip 000055570589ba34 sp 00007f9ca5486290 error 15

In both cases no crashdump information is available in apport. Just messages list this:

ERROR: apport (pid 26217) Wed Jun 9 06:29:59 2021: host pid 24140 crashed in a container without apport support  
ERROR: apport (pid 24822) Thu Jun 10 08:53:54 2021: host pid 23366 crashed in a separate mount namespace, ignoring

The Ubuntu host is a VM running on vmware. I have tried to migrate the VM to different physical hardware, and the errors persist regardless of underlying hardware.

What can I do to identify cause?  
Any suggestions for workaround?

---

<div class="post-metadata">

**Author:** ![OdysLam](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/odyslam/32/98_2.png) [@OdysLam](https://community.netdata.cloud/u/OdysLam)\
**Post date:** [June 10, 2021, 1:23pm UTC](https://community.netdata.cloud/t/cpu-traps-segfault/1418/2 "2021-06-10T13:23:46Z")

</div>

Hi @sdo and welcome back!

I have contacted our engineers and we will see this shortly. It sounds indeed disturbing. We are sorry that you experience this.

We will get it resolved 💪

---

<div class="post-metadata">

**Author:** ![Vasilis\_Kalintiris](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/vasilis_kalintiris/32/343_2.png) [@Vasilis\_Kalintiris](https://community.netdata.cloud/u/Vasilis_Kalintiris)\
**Post date:** [June 10, 2021, 3:07pm UTC](https://community.netdata.cloud/t/cpu-traps-segfault/1418/3 "2021-06-10T15:07:28Z")

</div>

Hi @sdo, thanks for reporting this!

I have a couple questions mostly meant to understand a little bit better what your setup looks like:

- Which installation method did you use to install Netdata?
- What is the output of `cat /etc/lsb-release /etc/os-release` and `netdata -W buildinfo`?
- Is it possible to provide the contents of netdata’s `error.log`?

Finally, there was [a similar issue opened on Github](https://github.com/netdata/netdata/issues/11184) a while ago. It might be worthwhile to follow the steps mentioned in that issue to rule out this one being a duplicate.

---

<div class="post-metadata">

**Author:** ![Vasilis\_Kalintiris](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/vasilis_kalintiris/32/343_2.png) [@Vasilis\_Kalintiris](https://community.netdata.cloud/u/Vasilis_Kalintiris)\
**Post date:** [June 24, 2021, 9:01am UTC](https://community.netdata.cloud/t/cpu-traps-segfault/1418/4 "2021-06-24T09:01:27Z")

</div>

Hi @sdo,

I’m curious if there’s any update on this issue. Is the Netdata agent still crashing or did you manage to fix the problem in some other way?
