# Netdata nightly fails to update

**URL:** <https://community.netdata.cloud/t/netdata-nightly-fails-to-update/722>\
**Category:** Help\
**Tags:** agent, agent-health\
**Created:** [January 4, 2021, 3:35pm UTC](https://community.netdata.cloud/t/netdata-nightly-fails-to-update/722 "2021-01-04T15:35:42Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![chris.pollock](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/chris.pollock/32/193_2.png) [@chris.pollock](https://community.netdata.cloud/u/chris.pollock)\
**Post date:** [January 4, 2021, 3:35pm UTC](https://community.netdata.cloud/t/netdata-nightly-fails-to-update/722/1 "2021-01-04T15:35:42Z")

</div>

See my post here [https://community.netdata.cloud/t/periodically-anacron-job-cron-daily-on-localhost-reports-a-problem-with-netdata-updater-sh/612](https://community.netdata.cloud/t/periodically-anacron-job-cron-daily-on-localhost-reports-a-problem-with-netdata-updater-sh/612) apparently this bug has crept into the updater script again this morning as the anacron job reported:

```
/tmp/netdata-updater-h2wewZhdXo/netdata-updater.sh: line 352: THIS_SHOULD_BE_REPLACED_BY_INSTALLER_SCRIPT: No such file or directory
run-parts: /etc/cron.daily/netdata-updater exited with return code 1

```

Running the kickstart scrip manually shows:

```
    chris@localhost:/var/crash$ bash <(curl -Ss https://my-netdata.io/kickstart.sh)
 --- Found existing install of Netdata under: / --- 
 --- Attempting to update existing install instead of creating a new one --- 
[/var/crash]$ sudo //usr/libexec/netdata/netdata-updater.sh --not-running-from-cron Checking if a newer version of the updater script is available.
Downloading newest version of updater script.
/tmp/netdata-updater-6QJ8iinT9b/netdata-updater.sh: line 354: THIS_SHOULD_BE_REPLACED_BY_INSTALLER_SCRIPT: No such file or directory
 FAILED  

 ABORTED Failed to update existing Netdata install 

```

Running the kickstart script with the --reinstall option did successfully install the nightly update.

---

<div class="post-metadata">

**Author:** ![haydenseitz](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/haydenseitz/32/234_2.png) [@haydenseitz](https://community.netdata.cloud/u/haydenseitz)\
**Post date:** [January 5, 2021, 9:12pm UTC](https://community.netdata.cloud/t/netdata-nightly-fails-to-update/722/2 "2021-01-05T21:12:18Z")

</div>

I’m also having this happen again

---

<div class="post-metadata">

**Author:** ![Austin\_Hemmelgarn](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/austin_hemmelgarn/32/4495_2.png) [@Austin\_Hemmelgarn](https://community.netdata.cloud/u/Austin_Hemmelgarn)\
**Post date:** [January 8, 2021, 12:07pm UTC](https://community.netdata.cloud/t/netdata-nightly-fails-to-update/722/3 "2021-01-08T12:07:51Z")

</div>

This is a known issue unintentionally introduced by some changes that were intended to make recovery from cases like this easier.

There’s an open PR to fix it ([Fixed handling of environment file in updater script. by Ferroin · Pull Request #10447 · netdata/netdata · GitHub](https://github.com/netdata/netdata/pull/10447)), but review has been a bit slow as many of our developers are still not back from vacation yet. Once that’s merged though, this issue should resolve itself without requiring any user intervention.

---

<div class="post-metadata">

**Author:** ![chris.pollock](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/chris.pollock/32/193_2.png) [@chris.pollock](https://community.netdata.cloud/u/chris.pollock)\
**Post date:** [January 8, 2021, 5:32pm UTC](https://community.netdata.cloud/t/netdata-nightly-fails-to-update/722/4 "2021-01-08T17:32:26Z")

</div>

Thanks @Austin_Hemmelgarn, appreciate the updated info. I take it this is the reason that the nightly is still on **`v1.28.0-68-nightly`**?

---

<div class="post-metadata">

**Author:** ![Austin\_Hemmelgarn](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/austin_hemmelgarn/32/4495_2.png) [@Austin\_Hemmelgarn](https://community.netdata.cloud/u/Austin_Hemmelgarn)\
**Post date:** [January 8, 2021, 5:35pm UTC](https://community.netdata.cloud/t/netdata-nightly-fails-to-update/722/5 "2021-01-08T17:35:25Z")

</div>

I hate to be this vague, but the best I can say is that this is most likely the cause of being on that particular version still.

I’m a bit hesitant given recent history with the updater to say for certain that this is in fact the cause though, for all I know there could be another bug causing it in there somewhere (though I don’t think this is likely).

---

<div class="post-metadata">

**Author:** ![chris.pollock](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/chris.pollock/32/193_2.png) [@chris.pollock](https://community.netdata.cloud/u/chris.pollock)\
**Post date:** [January 10, 2021, 4:39pm UTC](https://community.netdata.cloud/t/netdata-nightly-fails-to-update/722/6 "2021-01-10T16:39:36Z")

</div>

This morning there was an update from **`v1.28.0-68-nightly`** to **`v1.28.0-93-nightly`**. Running the kickstarter script gave the usual

```
bash <(curl -Ss https://my-netdata.io/kickstart.sh)
 --- Found existing install of Netdata under: / --- 
 --- Attempting to update existing install instead of creating a new one --- 
[/home/chris]$ sudo //usr/libexec/netdata/netdata-updater.sh --not-running-from-cron Checking if a newer version of the updater script is available.
Downloading newest version of updater script.
/tmp/netdata-updater-AaNchL31yc/netdata-updater.sh: line 354: THIS_SHOULD_BE_REPLACED_BY_INSTALLER_SCRIPT: No such file or directory
FAILED  

```

However running with --reinstall did work.
