# run-parts: failed to stat component /etc/cron.daily/netdata-updater: No such file or directory

**URL:** <https://community.netdata.cloud/t/run-parts-failed-to-stat-component-etc-cron-daily-netdata-updater-no-such-file-or-directory/3474>\
**Category:** Help\
**Tags:** installation, agent\
**Created:** [November 3, 2022, 11:54am UTC](https://community.netdata.cloud/t/run-parts-failed-to-stat-component-etc-cron-daily-netdata-updater-no-such-file-or-directory/3474 "2022-11-03T11:54:51Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mauro](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/mauro/32/2292_2.png) [@Mauro](https://community.netdata.cloud/u/Mauro)\
**Post date:** [November 3, 2022, 11:54am UTC](https://community.netdata.cloud/t/run-parts-failed-to-stat-component-etc-cron-daily-netdata-updater-no-such-file-or-directory/3474/1 "2022-11-03T11:54:51Z")

</div>

Hi.

On Ubuntu 20.04, I have [installed the agent](https://learn.netdata.cloud/docs/agent/packaging/installer/), then decided to [uninstall it](https://learn.netdata.cloud/docs/agent/packaging/installer/uninstall).

I followed the instructions.

Now, every day, I am getting:

```auto
run-parts: failed to stat component /etc/cron.daily/netdata-updater: No such file or directory

```

Which tells me something wasn’t cleaned completely.

Does anyone know the steps I could take, or which program is attempting to run this particular cron?

Thanks.

---

<div class="post-metadata">

**Author:** ![Francisco\_Vitorino](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/francisco_vitorino/32/2295_2.png) [@Francisco\_Vitorino](https://community.netdata.cloud/u/Francisco_Vitorino)\
**Post date:** [November 3, 2022, 6:59pm UTC](https://community.netdata.cloud/t/run-parts-failed-to-stat-component-etc-cron-daily-netdata-updater-no-such-file-or-directory/3474/2 "2022-11-03T18:59:37Z")

</div>

Same thing, weird. Any solutions or workaround?

---

<div class="post-metadata">

**Author:** ![Austin\_Hemmelgarn](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/austin_hemmelgarn/32/4495_2.png) [@Austin\_Hemmelgarn](https://community.netdata.cloud/u/Austin_Hemmelgarn)\
**Post date:** [November 4, 2022, 2:55pm UTC](https://community.netdata.cloud/t/run-parts-failed-to-stat-component-etc-cron-daily-netdata-updater-no-such-file-or-directory/3474/3 "2022-11-04T14:55:51Z")

</div>

This appears to be a bug in the uninstaller code.

You should be able to work around the issue by simply manually removing `/etc/cron.daily/netdata-updater`.

---

<div class="post-metadata">

**Author:** ![Mauro](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/mauro/32/2292_2.png) [@Mauro](https://community.netdata.cloud/u/Mauro)\
**Post date:** [November 4, 2022, 3:19pm UTC](https://community.netdata.cloud/t/run-parts-failed-to-stat-component-etc-cron-daily-netdata-updater-no-such-file-or-directory/3474/4 "2022-11-04T15:19:15Z")

</div>

Thank you! Seems I misread the error message. Indeed this was caused by a leftover link in `/etc/cron.daily`

---

<div class="post-metadata">

**Author:** ![Francisco\_Vitorino](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/francisco_vitorino/32/2295_2.png) [@Francisco\_Vitorino](https://community.netdata.cloud/u/Francisco_Vitorino)\
**Post date:** [November 15, 2022, 8:55am UTC](https://community.netdata.cloud/t/run-parts-failed-to-stat-component-etc-cron-daily-netdata-updater-no-such-file-or-directory/3474/5 "2022-11-15T08:55:26Z")

</div>

I did that but the server still keeps emailing me that same error code.

---

<div class="post-metadata">

**Author:** ![Francisco\_Vitorino](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/francisco_vitorino/32/2295_2.png) [@Francisco\_Vitorino](https://community.netdata.cloud/u/Francisco_Vitorino)\
**Post date:** [November 30, 2022, 8:17am UTC](https://community.netdata.cloud/t/run-parts-failed-to-stat-component-etc-cron-daily-netdata-updater-no-such-file-or-directory/3474/6 "2022-11-30T08:17:02Z")

</div>

@Austin_Hemmelgarn I manually removed that file but I keep getting those warnings on my webserver. What else do I need to clean? Would installing netdata and uninstalling work better? Thanks
