# Unable to start netdata after installing latest nightly build

**URL:** <https://community.netdata.cloud/t/unable-to-start-netdata-after-installing-latest-nightly-build/3223>\
**Category:** Help\
**Tags:** agent\
**Created:** [August 23, 2022, 2:54pm UTC](https://community.netdata.cloud/t/unable-to-start-netdata-after-installing-latest-nightly-build/3223 "2022-08-23T14:54:41Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![balajis](https://avatars.discourse-cdn.com/v4/letter/b/94ad74/32.png) [@balajis](https://community.netdata.cloud/u/balajis)\
**Post date:** [August 23, 2022, 2:54pm UTC](https://community.netdata.cloud/t/unable-to-start-netdata-after-installing-latest-nightly-build/3223/1 "2022-08-23T14:54:42Z")

</div>

Unable to start netdata agent after installing

root@cnmaestro:/var/cache/netdata/dbengine# netdata -W buildinfo  
Version: netdata v1.36.0-40-nightly  
Configure options: ‘–build=x86\_64-linux-gnu’ ‘–includedir=${prefix}/include’ ‘–mandir=${prefix}/share/man’ ‘–infodir=${prefix}/share/info’ ‘–disable-silent-rules’ ‘–libdir=${prefix}/lib/x86\_64-linux-gnu’ ‘–libexecdir=${prefix}/lib/x86\_64-linux-gnu’ ‘–disable-maintainer-mode’ ‘–prefix=/usr’ ‘–sysconfdir=/etc’ ‘–localstatedir=/var’ ‘–libdir=/usr/lib’ ‘–libexecdir=/usr/libexec’ ‘–with-user=netdata’ ‘–with-math’ ‘–with-zlib’ ‘–with-webdir=/var/lib/netdata/www’ ‘–disable-dependency-tracking’ ‘build\_alias=x86\_64-linux-gnu’ ‘CFLAGS=-g -O2 -fdebug-prefix-map=/usr/src/netdata=. -fstack-protector-strong -Wformat -Werror=format-security’ ‘LDFLAGS=-Wl,-Bsymbolic-functions -Wl,-z,relro’ ‘CPPFLAGS=-Wdate-time -D\_FORTIFY\_SOURCE=2’ ‘CXXFLAGS=-g -O2 -fdebug-prefix-map=/usr/src/netdata=. -fstack-protector-strong -Wformat -Werror=format-security’  
Install type: binpkg-deb  
Binary architecture: x86\_64  
Packaging distro:  
Features:  
dbengine: YES  
Native HTTPS: YES  
Netdata Cloud: YES  
ACLK: YES  
TLS Host Verification: YES  
Machine Learning: YES  
Stream Compression: YES  
Libraries:  
protobuf: YES (system)  
jemalloc: NO  
JSON-C: YES  
libcap: NO  
libcrypto: YES  
libm: YES  
tcalloc: NO  
zlib: YES  
Plugins:  
apps: YES  
cgroup Network Tracking: YES  
CUPS: YES  
EBPF: YES  
IPMI: YES  
NFACCT: YES  
perf: YES  
slabinfo: YES  
Xen: NO  
Xen VBD Error Tracking: NO  
Exporters:  
AWS Kinesis: NO  
GCP PubSub: NO  
MongoDB: NO  
Prometheus Remote Write: YES

Error log snippet:  
2022-08-23 14:54:13: netdata INFO : MAIN : TIMEZONE: using the contents of /etc/timezone  
2022-08-23 14:54:13: netdata INFO : MAIN : TIMEZONE: fixed as ‘Etc/UTC’  
2022-08-23 14:54:13: netdata INFO : MAIN : SIGNAL: Not enabling reaper  
2022-08-23 14:54:13: netdata INFO : MAIN : resources control: allowed file descriptors: soft = 1024, max = 524288  
2022-08-23 14:54:13: netdata INFO : MAIN : Out-Of-Memory (OOM) score is already set to the wanted value 0  
2022-08-23 14:54:13: netdata INFO : MAIN : Adjusted netdata scheduling policy to batch (3), with priority 0.  
2022-08-23 14:54:13: netdata INFO : MAIN : Running with process scheduling policy ‘batch’, nice level 19  
2022-08-23 14:54:13: netdata INFO : MAIN : netdata started on pid 64235.  
2022-08-23 14:54:13: netdata INFO : MAIN : Initializing spawn client.  
2022-08-23 14:54:13: netdata INFO : MAIN : Executing /usr/libexec/netdata/plugins.d/system-info.sh  
Spawn server is up.  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_CONTAINER\_OS\_NAME=none  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_CONTAINER\_OS\_ID=none  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_CONTAINER\_OS\_ID\_LIKE=none  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_CONTAINER\_OS\_VERSION=none  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_CONTAINER\_OS\_VERSION\_ID=none  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_CONTAINER\_OS\_DETECTION=none  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_CONTAINER\_IS\_OFFICIAL\_IMAGE=false  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_HOST\_OS\_NAME=Ubuntu  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_HOST\_OS\_ID=ubuntu  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_HOST\_OS\_ID\_LIKE=debian  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_HOST\_OS\_VERSION=20.04.4 LTS (Focal Fossa)  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_HOST\_OS\_VERSION\_ID=20.04  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_HOST\_OS\_DETECTION=/etc/os-release  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_HOST\_IS\_K8S\_NODE=false  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_KERNEL\_NAME=Linux  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_KERNEL\_VERSION=5.11.0-46-generic  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_ARCHITECTURE=x86\_64  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_VIRTUALIZATION=vmware  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_VIRT\_DETECTION=systemd-detect-virt  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_CONTAINER=unknown  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_CONTAINER\_DETECTION=systemd-detect-virt  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_CPU\_LOGICAL\_CPU\_COUNT=4  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_CPU\_VENDOR=GenuineIntel  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_CPU\_MODEL=Intel(R) Xeon(R) Platinum 8280 CPU @ 2.70GHz  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_CPU\_FREQ=2693000000  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_CPU\_DETECTION=lscpu  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_TOTAL\_RAM=8340815872  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_RAM\_DETECTION=procfs  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_TOTAL\_DISK\_SIZE=192518553600  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_SYSTEM\_DISK\_DETECTION=sysfs  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_INSTANCE\_CLOUD\_TYPE=unknown  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_INSTANCE\_CLOUD\_INSTANCE\_TYPE=unknown  
2022-08-23 14:54:14: netdata INFO : MAIN : NETDATA\_INSTANCE\_CLOUD\_INSTANCE\_REGION=unknown  
2022-08-23 14:54:14: netdata ERROR : MAIN : Failed to initialize database at /mnt/data/netdata/netdata-meta.db, due to “unable to open database file”  
2022-08-23 14:54:14: netdata FATAL : netdata : Failed to initialize SQLite # : Success

2022-08-23 14:54:14: netdata INFO : MAIN : /usr/libexec/netdata/plugins.d/anonymous-statistics.sh ‘FATAL’ ‘netdata:netdata’ ‘0767@database/r:rrd\_init /0’  
2022-08-23 14:54:15: netdata ERROR : MAIN : Execution of anonymous statistics script returned http code 400.  
2022-08-23 14:54:15: netdata INFO : MAIN : EXIT: netdata prepares to exit with code 1…  
2022-08-23 14:54:15: netdata INFO : MAIN : /usr/libexec/netdata/plugins.d/anonymous-statistics.sh ‘EXIT’ ‘ERROR’ ‘-’  
2022-08-23 14:54:16: netdata ERROR : MAIN : Execution of anonymous statistics script returned http code 400.  
2022-08-23 14:54:16: netdata INFO : MAIN : EXIT: cleaning up the database…  
2022-08-23 14:54:16: netdata INFO : MAIN : Cleaning up database [0 hosts(s)]…  
2022-08-23 14:54:16: netdata INFO : MAIN : EXIT: removing netdata PID file ‘/var/run/netdata/netdata.pid’…  
2022-08-23 14:54:16: netdata INFO : MAIN : EXIT: all done - netdata is now exiting - bye bye…  
EOF found in spawn pipe.  
Shutting down spawn server event loop.  
Shutting down spawn server loop complete.

---

<div class="post-metadata">

**Author:** ![Manolis\_Vasilakis](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/manolis_vasilakis/32/820_2.png) [@Manolis\_Vasilakis](https://community.netdata.cloud/u/Manolis_Vasilakis)\
**Post date:** [August 23, 2022, 3:05pm UTC](https://community.netdata.cloud/t/unable-to-start-netdata-after-installing-latest-nightly-build/3223/2 "2022-08-23T15:05:26Z")

</div>

Hi @balajis ! Welcome to Netdata !

Looks like something off with the installation… How did you install? Kickstart script ?

Can you try to re-install ? You can try by passing the `--reinstall` flag to the kickstart script.

---

<div class="post-metadata">

**Author:** ![balajis](https://avatars.discourse-cdn.com/v4/letter/b/94ad74/32.png) [@balajis](https://community.netdata.cloud/u/balajis)\
**Post date:** [August 24, 2022, 4:36am UTC](https://community.netdata.cloud/t/unable-to-start-netdata-after-installing-latest-nightly-build/3223/3 "2022-08-24T04:36:56Z")

</div>

Hi @Manolis_Vasilakis ,  
I have installed through kickstart script. Even reinstall doesn’t work. Could you please help on this?

---

<div class="post-metadata">

**Author:** ![Manolis\_Vasilakis](https://yyz1.discourse-cdn.com/flex029/user_avatar/community.netdata.cloud/manolis_vasilakis/32/820_2.png) [@Manolis\_Vasilakis](https://community.netdata.cloud/u/Manolis_Vasilakis)\
**Post date:** [August 24, 2022, 8:12am UTC](https://community.netdata.cloud/t/unable-to-start-netdata-after-installing-latest-nightly-build/3223/4 "2022-08-24T08:12:03Z")

</div>

Sure! Can you please post the output (or maybe upload it somewhere) of the kickstart script?

Do you get the same errors when you try to run the agent?
