Rpi 4 failed to start kernel modules


  • Staff

    So you can’t edit the charts.d.conf and make the adjustments that are described in the blog post. Can you please send us the logs?


  • Staff

    @peter2cfu this new error that you are seeing is happening because you did not have the command let installed on your system. You can do the following steps that are analogous to edit-config command:

    # cd /etc/netdata
    # cp -a /usr/lib/netdata/conf.d/charts.d.conf .
    

    And after this you can follow the rest of the instructions.



  • This post is deleted!


  • @Thiago-Marques-0 thanks but seems that did not help, I had already manually copied this file over to this location thinking that may have been a possible issue.

    pi@blackhole:/etc/netdata $ sudo cp -a /usr/lib/netdata/conf.d/charts.d.conf .
    pi@blackhole:/etc/netdata $ sudo ./edit-config charts.d.conf
    ./edit-config: 10: /etc/profile.d/motd.sh: let: not found
    ./edit-config: 11: /etc/profile.d/motd.sh: arithmetic expression: expecting primary: "%60"
    pi@blackhole:/etc/netdata $
    

    charts.d.conf

    # This is the configuration for charts.d.plugin
    
    # Each of its collectors can read configuration eiher from this file
    # or a NAME.conf file (where NAME is the collector name).
    # The collector specific file has higher precedence.
    
    # This file is a shell script too.
    
    # -----------------------------------------------------------------------------
    
    # number of seconds to run without restart
    # after this time, charts.d.plugin will exit
    # netdata will restart it, but a small gap
    # will appear in the charts.d.plugin charts.
    #restart_timeout=$[3600 * 4]
    
    # when making iterations, charts.d can loop more frequently
    # to prevent plugins missing iterations.
    # this is a percentage relative to update_every to align its
    # iterations.
    # The minimum is 10%, the maximum 100%.
    # So, if update_every is 1 second and time_divisor is 50,
    # charts.d will iterate every 500ms.
    # Charts will be called to collect data only if the time
    # passed since the last time the collected data is equal or
    # above their update_every.
    #time_divisor=50
    
    # -----------------------------------------------------------------------------
    
    # the default enable/disable for all charts.d collectors
    # the default is "yes"
    # enable_all_charts="yes"
    
    # BY DEFAULT ENABLED MODULES
    # ap=yes
    # apcupsd=yes
    # libreswan=yes
    # nut=yes
    # opensips=yes
    
    # -----------------------------------------------------------------------------
    # THESE NEED TO BE SET TO "force" TO BE ENABLED
    
    # Nothing useful.
    # Just an example charts.d plugin you can use as a template.
    # example=force
    sensors = force
    


  • I may have found the issues, it runs when I do this:

    sudo bash ./edit-config charts.d.conf
    

    see https://stackoverflow.com/questions/42393137/let-command-is-not-found-in-my-bash-script for a full explanation…

    However seems this has no affect in regards to NetData operations, i’m starting to think either I am really missing something or this application not quite ready for Raspberry Pi…



  • However seems this has no affect in regards to NetData operations, i’m starting to think either I am really missing something or this application not quite ready for Raspberry Pi…

    Seems i’m in error a reboot sorted it out, if all else fails ‘reboot’ seems is not just for windows. 🙂


  • Staff

    @peter2cfu after the cp command, you will need to edit it with some editor that you like, I forgot to say this, I am sorry for this


  • Staff

    @peter2cfu after to edit the file, you need to restart Netdata, but it is not necessary to reboot the operate system, depending of your distribution, you can use systemctl command to send a restart, or you can combine the commands kill and netdata to restart it.

    Without any doubt, the reboot will work 😄 .



  • To recap:

    Raspbian kernel (GNU/Linux 10 (buster)) Pi does not support the ebpf.plugin and is not needed to read the onboard sensors of the Raspberry pi

    The command to run the NetData editor is:

    sudo bash ./edit-config charts.d.conf
    

    or just copy the .conf file you need to the /etc/netdata directory and edit with your favorite editor.

    To reboot the NetData service use one of the following commands.

    sudo service netdata restart
    
    netdata reboot
    
    sudo systemctl restart netdata
    

    If all else fails reboot.

    And now the temp sensors are working 🙂


  • Staff

    Hello @peter2cfu, except for

    netdada reboot
    

    All the other commands should work. For you restart Netdata manually you could use the following command sequence:

    netdatacli shutdown-agent
    netdata
    

    Give few seconds between the execution of the first and second command to be sure that Netdata exited without problems.

    We are glad that the sensors are working for you. 🙂


Log in to reply