Netdata Community

How to disable some of the cgroups charts from netdata

I have multiple docker containers in my system. And I want to disable following charts from netdata for all docker containers:

  • cgroup_system_services_config_ctr.cpu_limit
  • cgroup_system_services_config_ctr.cpu_per_core
  • cgroup_system_services_config_ctr.mem_utilization
  • net_duplex.eth0

I tried to disable it from netdata.conf as follows:

[cgroup_system_services_config_ctr.cpu_limit]
        enabled = no
[cgroup_system_services_config_ctr.cpu_per_core]
        enabled = no
[cgroup_system_services_config_ctr.mem_utilization]
        enabled = no

(system_services_config_ctr is docker container name)

Would you please tell me how to disable these charts? I don’t want to disable all cgroup charts. only few of them listed above needs to be disabled.

You can disable groups of charts in the [plugin:cgroups] section of netdata.conf

[plugin:cgroups]
	# cgroups plugin resource charts = yes
	# enable cpuacct stat (total CPU) = auto
	# enable cpuacct usage (per core CPU) = auto
	# enable memory = auto
	# enable detailed memory = auto
	# enable memory limits fail count = auto
	# enable swap memory = auto
	# enable blkio bandwidth = auto
	# enable blkio operations = auto
	# enable blkio throttle bandwidth = auto
	# enable blkio throttle operations = auto
	# enable blkio queued operations = auto
	# enable blkio merged operations = auto
	# enable cpu pressure = auto
	# enable io some pressure = auto
	# enable io full pressure = auto
	# enable memory some pressure = auto
	# enable memory full pressure = auto
	# enable systemd services = yes
	# enable systemd services detailed memory = yes
	# report used memory = yes

You can see all available options using the http://localhosti:19999/netdata.conf endpoint.

@vlvkobal Thanks for your help.
But I couldn’t find the configuration for following charts. I need to disable them. Would you please have a look and share the list of config options for following particular charts?

  • CPU Usage within the limits (cgroup_xxxx_ctr.cpu_limit)
  • Memory Activity (cgroup_xxxx_ctr.mem_activity)
  • Memory Page Faults (cgroup_xxxx_cr.pgfaults) →
  • Memory Utilization (cgroup_xxxx_ctr.mem_utilization) →
  • Used RAM within the limits (cgroup_xxxx_ctr.mem_usage_limit)

Thank you so much in advance

Just for your information, I have successfully disabled fallowing charts:

CPU Usage (100% = 1 core) Per Core (cgroup_xxxx_ctr.cpu_per_core)
Interface Duplex State (net_duplex)
	enable cpuacct stat (total CPU) = no
	enable memory = no
	enable detailed memory = no

It disables not the exact list of charts you mentioned. If you need to be picky, you should disable every chart for every group separately.

@vlvkobal Thank you so much for information.

If you need to be picky, you should disable every chart for every group separately.

Yes. I need to disable exact charts listed above. How to disable every chart for every group separately? Would you please tell me.?

Thank you so much in advance !

Look at sections under # per chart configuration. An example for disabling an exact chart - a mem usage chart for a MongoDB docker container:

[cgroup_mongo.mem_usage]
	enabled = no

I see. Thanks for quick response.
Is there any pattern to apply this change for all containers without listing out all container names?
Lets say I have N number of docker containers, each container has charts for “Memory Utilization” etc
So is there any way to disable “Memory Utilization” charts for all containers without listing out each container name?
For example:

[cgroup_*.mem_utilization]
        enabled = no

@vlvkobal
As you suggested, I tried the following and unfortunately its not working. I think I did something wrong may be. After changing this in netdata.conf I restarted netdata service and checked, but mem_usage graph is still there for this particular container.

[cgroup_<container_name>.mem_usage]
	enabled = no

You probably saw the chart that wasn’t being updated. Have you reloaded the dashboard after Netdata restarted?

Yes. reloaded the dashboard multiple times. even checked after rebooting the machine. but still I can see that particular chart.

It’s strange. I’ve checked it on my VM with a mongodb container - everything works as expected. Please check your effective configuration using the http://localhost:19999/netdata.conf endpoint.