Netdata Community

Interface package drops when connecting a device to wlan

Environment

I’m running the latest netdata agent on my proxmox node and on all vm’s.
For my wireless network I’m using UniFi access points. The UniFi Cloud Key runs in a Docker container within a VM virtualized by said hypervisor.

Problem/Question

Every time I connect a device to my wireless network, all VMs drop packets and netdata triggers an alarm. How can I analyze this further?

What I expected to happen

I want to know what is causing this alarm because it is really annoying and I want to fix it. Netdata unfortunately does not show me any hint which package exactly is being dropped. I know this may not be the right place to ask this question, but I have no idea who else to ask.

Hey @Lamera and welcome to our community!

Your use-case seems very interesting, using that many Netdata Agents. Have you tried Netdata Cloud?

Now, in terms of your question, although I personally don’t have any experience, I found a relevant thread in our GitHub, where various users discussed in regards to packets being dropped and how to detect this. Please do tell me if you find it useful.

Hi @OdysLam :smiley:

Thanks for your reply.
Finally, I found the packet that is causing this false alarm (see picture below). Thanks to this issue in github.
With ebtables -A INPUT -p 890d -j DROP on the proxmox hypervisor, the alarm is gone on this node. But all virtual machines still get this alarm.
And also this hotfix is not permanent. After a reboot the alarm is back again.
I think the only thing I can do now is configure this alert different on the netdata agent.