Netdata Community

Configure custom notification in cloud version

Hello, can anybody helps me, how i can configure custom notification in cloud version? For ex. send telegram message. Thanks!

You are welcome @Артём-Мосс !
Please, let us know if you have any doubt.

Best regards!

Thanks for all, to much detailed :slight_smile:

Thanks Thiago for replying in detail. Top notch support <3

Hello @Артём-Мосс ,

To configure Telegram as a receiver, you need to do the following steps:

# cd /etc/netdata/
# ./edit-config health_alarm_notify.conf

When it opens the file with your favorite text editor, you will need to change or add the following variables:

SEND_TELEGRAM="YES"
TELEGRAM_BOT_TOKEN="XXXXXXXXX:YYYYYYYYYY-ZZZZZ"
DEFAULT_RECIPIENT_TELEGRAM="-1111111111"

To get the values for the bot token and default recipient, please, take a look at our documentation.

Please, let us know whether you need additional help.

Best regards!

Hey,

At the moment, the alarms are still configured on a per-agent basis, as per our documentation. Central Notifications center is on it’s way!

Is there a way to disable cloud notifications? Since claiming my nodes in Netdata Cloud, I get alarms from the agent to our defined recipients and also from cloud to my cloud user email address.

@haydenseitz we will soon ship alarm and reachability notifications via email.
Currently to disable these, you need to add a “key : value” pair “alarm-notifications-management : true” in your browser local storage.

For example in Chrome -> Developer Tools -> Application -> Local Storage -> Staging -> add a “key : value” pair “alarm-notifications-management : true”.

Then go to Profile/Notifications and set your personal email notification configuration as you wish . If you are an admin you can go to Manage Space/Notifications and disable email notifications for all users in the Space.

Application was “app.netdata.cloud” in my case.

However, after setting all war rooms (via profile) to critical only (saved setting), still receive a flood of emails which are warning only. Also tried setting to ‘no notification’, still receive warning emails. I have stopped all agents until resolved.

Disabling email notifications on the Space prevents all emails being sent - this works.

If there was message summarisation that would help, way too many recurring alerts (regardless of where they go to).

Also, before modifying notifications we did not receive notification when agents were unreachable… now we do.

@baitnetdata @haydenseitz @111 We shipped alarm notifications via email. Next year we will offer more integrations. Thanks for your patience.