Netdata Community

How to fix the MACHINE_GUID?

Hi all,

First off I really like netdata and the simplicity of adding plugins for custom purposes. However I ran into an issue.

I’m running on a system with a read only /var directory which uses an overlayfs. The system is setup as a collector and streams the data to a host.
The overlayfs results in netdata regenerating the MACHINE_GUID as part of the registry on every boot. Which results in a new instance in the dashboard.

I’d like to prevent netdata from generating a new instance in my dashboard on every reboot.

Any thoughts?

Thanks in advance.

Go through https://learn.netdata.cloud/docs/agent/configuration-guide and https://learn.netdata.cloud/docs/agent/daemon/config
There’s an instruction in the empty netdata.conf that tells you how you can get the entire file of default options, but it’s better if you just add the options you change, otherwise it’s just too big, with all the commented out default values and you can get lost.

Thnx! I couldn’t find the configuration option in netdata.conf but apparently I’m not working with the default config… Because my host does have this option.

Hi @flitjes, just set the “lib directory” in netdata.conf ([global] section) to a persistent directory that is readable/writeable by netdata and that’s what it will use.