Netdata Community

Megacli in dashboard

Environment

proxmox server

Problem/Question

I have two proxmox servers that I am trying to get megacli monitoring working. I followed the guide:

I did enable the megacli by ./edit-config python.d.conf

What I expected to happen

Would like to see it on the dashboard and I do not see it after I enabled it.
Was there more to the configuration?

1 Like

If you followed the configuration to the letter, then it should be working.

Can you please send us the logs, as shown in the documentation?

To do this, follow the documentation to find the log file and use the following command: less /var/log/netdata/error.log. Copy the output and send it here.

Don’t worry, we will get to the bottom of this!

Documentation:

Hi @willb0t

Would like to see it on the dashboard and I do not see it after I enabled it.

Have you restarted netdata service after?

If yes and the problem exists, i suggest to run megacli collector in the debug mode:

First, navigate to your plugins directory, usually at /usr/libexec/netdata/plugins.d/ . If that’s not the case on your system, open netdata.conf and look for the setting plugins directory . Once you’re in the plugin’s directory, switch to the netdata user.

cd /usr/libexec/netdata/plugins.d/ 
sudo -u netdata -s

You can now run the python.d.plugin to debug the collector:

./python.d.plugin debug nolock megacli

If it works in the debug mode, then the problem is likely systemd unit capabilities, megacli uses sudo and netdata.service unit doesnt have needed permissions.

The fix is Adaptec RAID plugin bug · Issue #10079 · netdata/netdata · GitHub

mkdir /etc/systemd/system/netdata.service.d; echo -e '[Service]\nCapabilityBoundingSet=~' | tee /etc/systemd/system/netdata.service.d/unset-capability-bounding-set.conf
systemctl daemon-reload
systemctl restart netdata.service