Netdata Community

No cloud monitoring anymore using Yunohost package

Environment

Raspberry Pi 4

Problem/Question

yunohost server
version 1.26
Recently cloud monitoring stopped working after an update.
Says:
This agent was built with > Running your great on raspberry pi4 (yunohost server).

version 1.26

Recently cloud monitoring stopped working after an update.

Says:

This agent was built with --disable-cloud and cannot be claimed and cannot be claimed

What I expected to happen

Previously could see monitoring info on a cloud, now only directly connecting to my server

Hey @sharicov,

Just to verify, how did you install the Netdata Agent? Did you use kickstart. sh or did you use the package manager of the linux distribution?

This seems very strange and it must be frustrating that after the update it doesn’t work. I don’t know what may be the cause, but let me ping my colleagues and we will come back with more information!

Thanks for your patience :slight_smile:

Thank you very much for the quick response, initially installed it via yunohost installation mechanism, source is here: https://github.com/YunoHost-Apps/netdata_ynh
Update was also done via yunohost interface.

I took a look here: https://github.com/YunoHost-Apps/netdata_ynh

This is not maintained by Netdata and in description I see they have disabled the cloud support:

We would have to go and ask the maintainers of “Yunohost Netdata” about why they have decided to disable the Cloud. If the reason is technical in nature we might help them make it work. If they disabled the Cloud due to some “philosophical” reason not sure what we can do.

Looking at their patch here: https://github.com/YunoHost-Apps/netdata_ynh/commit/d75af1f5ecfbde05fdfd72f761e545bca8a30bdf

they seem to be disabling cloud on purpose.

I asked about this on their GitHub https://github.com/YunoHost-Apps/netdata_ynh/issues/52
In case reason for disabling Cloud is technical I will go ahead and try help them resolve it.

Hey @sharicov,

If you are happy with the answer by @underhood, please don’t forget to mark the topic as solved, by checking the post that solved your question, clicking on the 3 dots and then clicking on the box that says “solution”.

Chjeers!

@sharicov as you can see here https://github.com/YunoHost-Apps/netdata_ynh/issues/52 they decided to switch off Cloud support voluntarily (not due to some technical problem I can help them solve). I did explain to them even if Cloud is built and enabled we do not send any data unless user explicitly Claims the node.

It is however up to them to make a decision as it is their package/project.

What you can maybe do is comment on that issue to let them know there is in fact user interest for Cloud support…

On this point I will mark this forum topic as resolved (as the only way to change this is talking with that package maintainers).