Netdata Community

Today docker image not working

Environment

Docker on Debian

Problem/Question

the latest image update [ netdata/netdata:latest ] makes netdata unusable and docker logs shows errors like

web interface is not working

Error relocating /usr/sbin/netdata: _ZN6google8protobuf7Message21CheckTypeAndMergeFromERKNS0_11MessageLiteE: symbol not found

What I expected to happen

1 Like

Hey @spupuz,

We are very sorry for this. We are aware of a bug in our release process and we are working (frantically I may add) to resolve this.

@Austin_Hemmelgarn may have more context, since he is our DevOps magician.

Thank you for your patience :slight_smile:

thanks for your reply @OdysLam i hope in a new push of the image with error solved :slight_smile:

BTW @spupuz , welcome to our community!

Make sure you check all our categories and share any story/tip/question that you have!

Are you using Netdata in a production system or in a home-lab environment?

Quick status update on this:

This appears to be a result of a combination of a bug in our handling of Docker tags and what appears to be an issue with the current build of the master branch in Docker containers. The tagging bug should be fixed before the end of the day today (with the v1.28 stable images being properly rebuilt base don the correct version in the process). The issue with the latest master is being looked into right now.

2 Likes

Thanks @Austin_Hemmelgarn for this. I will ping and banner your answer for enhanced visibility.

image

Home Lab production :slight_smile:

2 Likes

Further update:

The issue with the image tagging has been fixed (so only the latest tag should update with tonight’s nightly build).

We’re still working on diagnosing the issues with the latest build itself, and are in the process of restoring the v1.28.0 and stable tags to the correct images.

I’ll report back with further updates when there’s something new to report.

We now have the v1.28.0 and stable tags fixed.

We’re still working on the latest tag.

And the latest tag should now be fixed too.

Still not certain what ent wrong, but it appears to have been a transient error of some sort.

1 Like