"update every" seems to be ignored

I’m locally monitoring 7 machines in a 1 parent - 6 Childs configuration. 4 of them are bare metal, the rest proxmox VMs. 1 ubuntu Lunar, all other debian bookworm/bullseye. All running latest buil (currently v1.42.0-361-nightly)
I’ve set in all 7 machines

update every = 2

but charts still get updated every second (with new values) instead of 2 seconds. I’ve tried also setting

[global statistics]
update every = 2

even though I believe it shouldn’t be necessary.

I’ve configured according to:


It seems simple enough and everything works perfectly except for this small detail. I’m sure I’ve overlooked something but cant really put my finger on it.

My (sanitized) stream.conf are:
#Child node
enabled = yes
destination = 192.XXX.XXX.XXX
timeout seconds = 60
default port = 19999
send charts matching = *
buffer size bytes = 1048576
reconnect delay seconds = 5
initial clock resync iterations = 60

#parent node

[API_KEY] is [YOUR-API-KEY], i.e [11111111-2222-3333-4444-555555555555]

enabled = yes
enable compression = yes
allow from = *
default memory mode = dbengine
health enabled by default = auto
default postpone alarms on connect seconds = 60
multiple connections = allow

Any help is appreciated,
Best regards,

Hi, @Carlos_Jesus. It is not ignored, regardless of the value of “update_every” the charts are always updated every second. But the data is collected every “update_every”. If you check the chart values, you will notice that they changed every “update_every”.

Yes. It is true.

I was misslead by the chart refresh, and the view point average.
Granularity is indeed correct. the “1 second point” in between updates are linear interpolations.

Thanks for your help and sorry for the noise…

best regards

1 Like