Alerts not using the node name, using original ip_XX name

So far I love Netdata - nice product. We’re an early stage startup and we’re looking forward to growing into a commercial user.


Alerts I am receiving via email are not referencing the assigned node name. Instead it is referencing the ‘original hostname’ when I first installed the agent - e.g. hostname is now set to ‘my-server’ but alerts are referencing ‘ip-XX.XX.XX.XX’

Background and environment

Ubuntu 20.x agents
For these servers the original hostname was using the default, e.g. ‘ip-XX.XX.XX.XX’, after agent install I renamed hostname and re-started the agent. The new node name is now correctly shown in the node list in Netdata Cloud, but alerts for the nodes still refer to the original node name (ip-XX.XX.XX.XX)

What I expected to happen

Alerts to reference the node name in the message, e.g. ‘my-server’

1 Like

Hi @tomtobin !

Can you try the following: In netdata.conf, go to section registry and setup the registry hostname entry to match the hostname. Remember to remove the leading # sign in front of the entry. Let us know if that works.


It is
hostname = XXX

not registry

And btw, I the default value just has what the machine returns to the hostname command.

Actually I just saw [BUG] Wrong hostname in alert emails · Issue #225 · netdata/netdata-cloud · GitHub
Are you referring to the node name of email alert notifications coming from Netdata Cloud too?

Thank you Christopher - the issue is just for the email notifications. I have changed the hostname setting in netdata.conf (as well as having changed the system hostname) and will let you know if that makes a difference - waiting for an alert.

e.g. in the email:

Chart: ipv4.tcphandshake
Family: tcp
Recovered from warning, (was warning for 1 second)

On Fri Jun 03 2022, 06:52:43 EDT
By: ip-172-25-X-XX <-------- the problem
Global time: Fri Jun 03 2022, 10:52:43 UTC

Classification: Errors
Role: sysadmin

Hello, this is still an issue for me - I have changed the netdata.conf hostname setting as well as having changed the server hostname. It seems once the device ID is registered in the Cloud with an original hostname it is never changed for alerts, even if the display name is updated. I would remove the node and re-add it to try to clear the stuck ip-XX.XX.XX.XX hostname, but we have no way to remove nodes (another issue I’ve submitted).

My next step will be to delete my account and start fresh, making sure the original registration uses the right hostname - but that is a lot of work (I think I have to manually delete the old registration from each node).

A simpler solution would be really appreciated if one exists! Great product, thank you.

Hi @tomtobin!

We will address the issue as soon as possible. In the mean time, have you also tried editing the registry hostname option too in netdata.conf?


Yes, I’ve changed the hostname parameter and restarted the service, no change. Thank you.

Hi @tomtobin

Can you please share to my email: manolis at netdata dot cloud the following bits:

  1. The output of netdata -W buildinfo
  2. Your netdata.conf
  3. The error.log file

Thanks !

This seems to be resolved! Thanks so much for addressing, not knowing which machine was alerting was a major challenge for us. You have a great product.

1 Like