Netdata Community

Alarm has wrong link

Environment

Ubuntu 18.04
netdata/bionic,now 1.9.0+dfsg-1 amd64 [installed]

Problem/Question

The email notification’s “View Netdata” button takes me to https://registry.my-netdata.io/… How can I change that?

What I expected to happen

Clicking on the link should take me to the server that sent the alert.

The first thing to do is to upgrade your Netdata. We’re at v1.31 now.
After that, you can sign in to Netdata cloud and then visit your agent’s UI. That records the URL you use.
The next time you get an alarm from that agent, you should be redirected correctly.

The alternative to using Netdata Cloud is to run your own registry.

Our registry stopped recording URL a while back, because there was no explicit opt-in for it to do so. Signing up to the cloud provides that opt-in and the local registry alternative provides the feature without sending any URLs to Netdata.