Netdata Community

Cannot install netdata from source (the source directory does not include netdata-installer.sh). Leaving all files in /tmp/netdata-kickstart-L0Qm7RAAZ F

Trying to install the agent on a cloud server on Digitalocean using an Ubuntu 18.04 droplet, with OpenLiteSpeed installed, and CyberPanel; and the error above appears.

Reinstalling does not help, same error.

Cannot post more than 2 links, so posting the error code here.

1 Like

Hi,

It seems to be an issue with the Google storage caching mechanism. Can you please try again and report back the results?

cc @Austin_Hemmelgarn for visibility.

Thanks!

Hi, tried twice. rebooted twice too. Same error.

Hm, I see. Thanks for sending again the output.

Can you test if you can execute scripts from the /tmp folder? I think that the problem is that the /tmp folder is set as an invalid directory for the user to execute scripts. Our installer downloads everything in /tmp folder and then attempts to install from there.

As per this GitHub issue:

Can you please try to use the $TMPDIR variable to a location other than /tmp, e.g ~/netdata If this doesn’t work, please try this suggestion:

In any case, we will get to the bottom of this!