Can't install on Ubuntu 20.04

Hello, I’m trying to install netdata on Ubuntu 20.04 without success. Thanks for any help.

Here is what command line says:

Hi @ermos! Welcome to Netdata.

This looks really weird… Basically it can’t write to /tmp/… I remember seeing something similar in the past, but there was no clear solution. Can you re-try? Likely after a reboot? Can you check the permissions of /tmp/ to see if everything is in order?

You could also try to specify a different temporary directory using the TMPDIR env variable when you run kickstart. Can you try with e.g. TMPDIR="/some/path" wget -O /tmp/ .... etc ?

Hello, @Manolis_Vasilakis thank you very much for the message.
1/ After reboot same problem.
2/ Permissions of /tmp/ are reading and writing for root but I also added my user w
3/ I ran the new command with TMPDIR as you suggested, but it all looks the same

The log is below

Hi @ermos

Can you try to run the kickstart script with sudo ? Don’t use TMPDIR now, let’s see what happens.

Before you do that though, after the failed run above, can you do an ls -l /tmp ?

Hi, @Manolis_Vasilakis thank you very much for the message. Here are the results of the two commands:

I would do this in two steps:

  1. Download the
  2. Then do TMPDIR=/mnt/foo/netdata sudo ./… (or better login as root and run it)

Hi, @Forza ,thank you very much for the message. The file is downloaded in /tmp and I also copied it to my Desktop. After I run your command, it gives me the following without and with root:

Hey @ermos .

It says “command not found” because you have included the 3 dots after the script name. I believe @Forza meant to suggest to use the arguments after the script name as per your original post, if you want.

So, can you please login as root (sudo su) and try to first download and then execute it with sh ?

1 Like

Thank you @Dim-P for the message. So I replaced the 3 dots by the rest of the command from the beginning (hope that’s what you meant) and tried it as a root both from the /Desktop/ and from the /tmp/ folder where the same file is downloaded. Still no success. The screenshot follows: