Docker version of Netdata


Am new to Docker and Netdata. I installed Netdata in Docker on my Dell Optiplex using the following link

This worked like a charm and I could immediately see the data via a Chrome browser at the local IP address I setup on the Dell and port 19999.

This week we had a power outage and the Dell was powered off without a graceful shutdown. When it powered back up, the Netdata link via the browser displayed nothing. I have removed the container and also Docker and reinstalled. When I run sudo docker ps -a I can see the Netdata container up and running and when I issue the command sudo netstat -ntlp | grep 19999 I see the following

tcp 0 0* LISTEN 1628/netdata
tcp6 0 0 :::19999 :::* LISTEN 1628/netdata

I have done a few hours of “Googling” but don’t seem to be getting anywhere, so any help would be great. I’m sure it’s something stupid that I did but just can’t seem to find the right answer to get this started again.


What do you mean by “nothing”? Can you post a screenshot?

I get the following message

This site can’t be reached took too long to respond.



My alternative would be to ditch Docker and just install the agent on the machine instead. FYI, I am running PiHole on this machine but not as a Docker container