Netdata Community

eBPF on RHEL7.9 rpm install

Hi,

Someone could confirm me that I need to install netdata from source to have eBPF plugin working ?

On my install by rpm from packagecloud, I added ebpf = yes under plugins section but I don’t see anything about eBPF after restarting netdata.

Thanks.

Hello @pdgaaa ,

I am not sure about the RPM packages, @Austin_Hemmelgarn are we delivering eBPF with RPM packages?

You can verify if the plugin was installed running the command:

$ ls ${NETDATA_PREFIX}/usr/libexec/netdata/plugins.d/ebpf.plugin

If you have the plugin installed, it is possible the SELinux is blocking you, I had to configure it manually on my CentOS 7.9, and we wrote a step-by-step here.

Thanks @Thiago_Marques_0 . I haven’t the plugin in ${NETDATA_PREFIX}/usr/libexec/netdata/plugins.d/ directory.

@Thiago_Marques_0 It looks like we tried to provide them but didn’t end up getting it actually working. I’ll try to sync up with you on Monday about figuring out exactly what is needed at this point.

All right, ping me when you are available.
Thank you @Austin_Hemmelgarn !

@pdgaaa according latest @Austin_Hemmelgarn answer, you will only have it available if you compile from source, but we will work on this next week.

I have updated netdata 1.26 rpm contain a empty ebpf.plugin · Issue #10200 · netdata/netdata · GitHub as the epbf plugin is still not avalaible on 1.31.0 rpm package.