fping Plugin missing

I’ve just built 4 new systems using Ubuntu 22.04 and noticed that there was no fping.plugin in

We tried to run up a couple of older VPS using Debian 10 which we have existing installations working fine and run the kickstarter script again - same issue. 1.37 installs fine but no fping.plugin file appears.

We can copy the file from an older install and build it but this is an extra step we would rather avoid.

The documents still detail this plugin with 1.37 so perhaps someone can advise what I am doing wrong in building that removed the plugin.



Hi, @stevenaj. The fping plugin has been deprecated (see v1.37.0 deprecation notice). The replacement is go.d/ping.

Thanks for letting me know. I had not seen this and was just using the instructions from the Netdata website. We’ve been using fping for a long time on Netdata builds so I never even thought to question that it had been removed :slight_smile:

Best wishes


@stevenaj can you remember or link to where in netdata website you saw this - just so we can go clean it up as needed in case others hit this too.

just had a quick look am guessing in here maybe: fping.plugin | Learn Netdata

@ilyam8 should we add a note in the docs there? To point to here instead? Ping monitoring with Netdata | Learn Netdata

I can do it but just wanted to double check.

The main reason is that fping is a third-party tool and it takes ages to add any changes (e.g. see my PR from April 12, still hanging).

I think the problem is

  • we don’t correctly communicate that 1.37.x is the stable release documentation, not the latest nightly.
  • sometimes users don’t really know what channel they are using (“just used kickstart”).

Not fping plugin problem, there are more things when 1.37.x != latest nightly.

Yes that is the one.
I have just configured it now on the build we have and it seems to be running but for the hell of it I can not find it on the Netdata dashboard :slight_smile:

I have probably just done this too quickly as my experience was with the fping plugin. It seems simple enough to add the hosts to the config file. I run the test to see it was indeed getting data from the hosts being pinged but when it comes to the Netdata panel I have lost the plot. Perhaps there is another step I am missing but the info I can read says the build should have it enabled and it looks so from netdata.conf and I just added the hosts section to the ping.conf and restarted netdata.

So sorry for being a little dumb with this so some handholding is probably needed as to why it didn’t seem as simple to setup as it did with the older fping plugin.


Both v1.37.0 and v1.37.1 stable builds have fping.plugin - technically the documentation is correct. I believe you are using Netdata nightly release, @stevenaj.

I agree that the stable/nigthly docs are confusing at the moment. And I don’t even say that the nightly doc version is WIP.