Netdata Community

Help to get fping visual in dashboard

Hello!

Please I need help,

First I’ve created an Hyper-V UbuntuServer Focal, I’ve installed netdata and fping with no problems, it’s functional and I can see it in dashboard. My problems come when I deployed the netdata docker in a Server, I’ve tried installing just as documentation said, but I had some issues, so i downloaded fping with wget and follow the installation, I’ve tested plugin with /usr/libexec/netdata/plugins.d/fping.plugin debug 1 and I have the same result as in my Hyper-V machine. The problem is that it doesn’t show in dashboards, I’ve been trying to compare all kind of config files, but nothing seems different.

Environment

Dockerized Netdata

Problem/Question

Not showing fping in dashboard

What I expected to happen

That fping is showed in dashboard

This is strange, do you see anything in the error log about fping? If the plugin returns correct info when you run it as the netdata user, then you should have the same behavior when it’s called from the netdata process.

It’s possible that the plugin is disabled, can you check the [plugins] section of http://yourhost:19999/netdata.conf

Have you set the setuid flag?
The corresponding part from /usr/libexec/netdata/plugins.d/fping.plugin:

    run mv src/fping /usr/local/bin/fping
    run chown root:root /usr/local/bin/fping
    run chmod 4755 /usr/local/bin/fping