Netdata Community



I need to have ipmi graphics on my Centos7 servers, and for that I need to use freeipmi.
By following the instructions at “freeipmi.plugin · Netdata Agent | Learn Netdata”, I have to do a re-install Netdata from source to create the freeipmi.plugin.
I cannot do it this way, as it would affect my operation.

Is someone has an idea to resolve this issue?

Best Regards

You can compile Netdata on another VM and then copy freeipmi.plugin to your production server.

Thanks for the solution, but it is not possible to execute.
In a VM ipmi does not work, so the plugin is not created anyway.

You don’t need ipmi to work to compile the plugin. You just need to install the relevant libraries.

I tried this many times already. With the libraries installed, the plugin is still not created. Because freeipmi does not run on a VM.

Well, I build Netdata on my VM without IPMI support

sudo ./ --enable-plugin-freeipmi

The output of the configure script while Netdata is being built:

checking for IPMIMONITORING... yes
checking for
     in -lipmimonitoring... yes
checking for ipmi_monitoring.h... yes
checking for ipmi_monitoring_bitmasks.h... yes
checking if freeipmi.plugin should be enabled... yes
[netdata]$ ls -al freeipmi.plugin
-rwxrwxr-x 1 root root 271552 Feb 25 10:05 freeipmi.plugin

Thanks. It worked.
I did it again and the plugin appeared to me.

A new problem now!!!
When I transfer the freeipmi.plugin don’t work in all servers…
When the Linux kernel is the same (kernel server 3.10 = kernel VM 3.10) it is working, but it does not work on a different kernel.

Any idea to resolve this issue?

I think the easiest way is to install the kernel you need and then switch to it and compile Netdata.