Issue when installing on Nginx server


I recently added Netdata on a server (Digital Ocean Nginx, managed via Gridpane) using Termius. Worked well, no issues. When I tried it again, something went wrong. For whatever reason, the password I thought I had copied & pasted was wrong and when I had to confirm the password again, for installing the software, I didn’t know what it was and the installation failed. The session has now timed out. I logged in again and tried to uninstall the Netdata installation using this line from the knowledge base ‘- --uninstall’. I added it to the line from GP kb page (How to setup Netdata on your GridPane Servers | GridPane), and basically this is what I added: ‘bash <(curl -Ss --uninstall’. This resulted in an error (see attached). Anyone come across this before - any ideas what to try next?


It’s pretty likely that the uninstaller failed because the agent did not get completely installed. As long as /etc/netdata/.environment does not exist, and command -v netdata doesn’t point to an actual executable, you should be fine to just run the installer normally and things should just work.

That said, the recommended way to run it is now curl > /tmp/ && sh /tmp/ instead of the older bash <() approach. Some parts of the install script actually depend on this to work correctly, though if you’re using the default options that may not be an issue.

Thank you for your reply. Just so that I completely understand your instructions (I’m new to this) -

instead of this line:

bash <(curl -Ss

I should be using this:

curl > /tmp/ && sh /tmp/

Is that correct?

Sorry about the delayed response here. Yes, you’re correct that the curl command you quoted (or alternatively, the equivalent with wget) is the preferred approach for running the kickstart script now.