Uninstall failed


I just tried to uninstall Netdata from a Digital Ocean server. The command line I ran was

‘wget -O /tmp/netdata-kickstart.sh https://my-netdata.io/kickstart.sh && sh /tmp/netdata-kickstart.sh --uninstall’

I ran it with ‘–dry-run’ first which seemed fine, I got the message “Would attempt to uninstall existing install” so I assumed it would be fine to run without the dry run. However, when I did I got a ‘Failed’ message: “FATAL: netdata-uninstaller.sh: FAILED TO UNINSTALL NETDATA: Failed to completely remove Netdata from this system”.

The line below said “Finished uninstalling the Netdata Agent.The following non-fatal warnings or errors were encountered:”, with “- Command “/tmp/netdata-kickstart-XXXXXXX (I removed code here)/netdata-uninstaller.sh --yes” failed with exit code 1.” at the very bottom.

I’m not sure what this means and if I can continue with installing Netdata again?


Hi @Monologue .

  1. Could you please do a sudo find / -d -name netdata and let me know what the result of that is?

  2. The first time you ran the uninstaller script, were you asked questions like the following? Did you answer yes in all cases?
    Do you want to delete this directory '/var/log/netdata' ? [y/n]
    Do you want to delete this directory '/etc/netdata' ? [y/n]
    Do you want to delete 'netdata' system group ? [y/n]

  3. If you see a message like netdata-uninstaller.sh: 699: .: Can't open /etc/netdata/.environment when you run the uninstaller script, it means that either:

  • Netdata was previously uninstalled successfully,
  • you didn’t use the kickstart.sh script to install Netdata, but you installed it in a custom way or
  • you installed Netdata using a non-default path, for example using --install-prefix (in which case, you should know where that path is and pass it over to kickstart.sh using --old-install-prefix ).

If you just run kickstart.sh to install Netdata with the default settings in the first place, it most likely uninstalled successfully by running wget -O /tmp/netdata-kickstart.sh https://my-netdata.io/kickstart.sh && sh /tmp/netdata-kickstart.sh --uninstall and you should be OK to reinstall it if you want.

This is the result of

Blockquote sudo find / -d -name netdata

As for your second question - no, I don’t think there were any questions like that. I’ve looked back at the session that was saved in Termius and I can’t see any questions there anyway.

In regards to your final statement - I’m not sure if the installation method I use is standard or custom. I use Gridpane to manage the sites on our servers so I used the installation guide they provide for Netdata: How to setup Netdata on your GridPane Servers | GridPane.