Netdata Community

Installation completely borked

I just tried to install the Netdata agent on a new Ubuntu 18.04 system.

Install script ran through until to the point where it tried to claim the node - then it yielded this:

Please note that I did provide my account’s password to the script and said account has sudo rights.

No amount of puttering around on my end got somewhere. So I ran the uninstall script which seemed to run through.

However, when I now try to run the install script again (the all-in-one version I got from my “War room => Add nodes”) then I just run straight into this same message again (as in: the exact same errors from the picture above)

Seems like the uninstall script does not actually remove all traces of the agent…

edit: Oh and bash <(curl -Ss https://my-netdata.io/kickstart.sh) yields this:

1 Like

Hey @Austin_Hemmelgarn, what do you make of this?

@Johannes_Hass I think that netdata got installed incorrectly the first time and now you have to use the --reinstall flag when running the kickstart script

My first thought is that Netdata got installed through the package manager at some point, in which case that needs to be cleared off before any other install method is safe.

@Johannes_Hass if you can confirm for certain that that is note the case, you can bypass the duplicate install protection by using the --allow-duplicate-install. We intentionally don’t document this option in the help text or online documentation because using it without knowing it’s safe (it should be safe here provided you don’t have a netdata package installed through the distro’s package manager) can lead to problems down the road (ironically, such problems tend to look very much like what you’re seeing here).

Unless the application Opencast installs Netdata, I cannot see how how Netdata could be installed through the package manager. I certainly did not do it. I’ll try your provided option, though.

Alright. The provided option worked for installation via bash <(curl -Ss https://my-netdata.io/kickstart.sh) --allow-duplicate-install

I then naively used the provided script from the Web-GUI which bombed out with this (sudoas you can see from my 2nd attempt also did not help)

Using sudo netdata-claim.sh -token=TOKEN -rooms=ROOM1,ROOM2 -url=https://app.netdata.cloud and copy and pasting the GUIDs from the GUI then worked, however. Might I suggest adding both the room and the claim token to your GUI as separate, copyable entries so that this step is a bit less ambiguous?

Otherwise, thanks for your help, it’s running now!