issue with netdata config / option is not used.

having a (probably) simple issue, I am running netdata on a single system with centos webpanel, its running, and I can edit the netdata config file, but when I make changes in [db] like, mode = dbengine and then restart the service and goto the url/netdata.conf it will show mode = save (even though that isn’t in the config at all) but will show something like # option ‘mode’ is not used. I’ve also tried other options as per the docs on the website, and i get this in the config file when checking on the website:

option ‘dbengine multihost disk space MB’ is not used.

update every = 1

option ‘storage tiers’ is not used.

storage tiers = 3

and it does this for everything, i cannot seem to figure this out on my own. any suggestions would be awesome. thanks

Hi @skwilla !

Question: Is this a new install? Did you have a netdata.conf before? Is it the first time you’re trying to edit it?

Why I’m asking, is because if you haven’t done yet any changes there, you can get a default netdata.conf by visiting http://server:19999/netdata.conf if you remove the netdata.conf you have currently.

Can you send it over to so I can have a look ?

Also, what version of the netdata agent are you running? Some options don’t apply to previous versions.

I have the same error
May be due to SAVE mode can not use tiers storage

You is not set mode = save ,but will fall back to SAVE mode when dbengine unavailable

	mode = save
	dbengine disk space MB = 2000
	retention = 43932
	update every = 2

	# option 'storage tiers' is not used.
	storage tiers = 3
	dbengine multihost disk space MB = 900

	# option 'dbengine tier 1 multihost disk space MB' is not used.
	dbengine tier 1 multihost disk space MB = 330

	# option 'dbengine tier 2 multihost disk space MB' is not used.
	dbengine tier 2 multihost disk space MB = 67