"section 'db' is not used."

Having installed netdata 1.33.1-2 on my openwrt router, I wanted to extend my history. So, I added the following snippet, which I’d found in the netdata documentation, to /etc/netdata/netdata.conf:

    mode = dbengine

    # per second data collection
    update every = 1

    # number of tiers used (1 to 5, 3 being default)
    storage tiers = 3

    # Tier 0, per second data
    dbengine multihost disk space MB = 256

    # Tier 1, per minute data
    dbengine tier 1 multihost disk space MB = 128
    dbengine tier 1 update every iterations = 60

    # Tier 2, per hour data
    dbengine tier 2 multihost disk space MB = 64
    dbengine tier 2 update every iterations = 60

After restarting the netdata service, however, I noticed no change after a few days. I still had the same short window of statistical data.

Having googled around a bit, I discovered I could access http://<router_ip>:19999/netdata.conf in order to see the active configuration. In this, I found:

# per chart configuration

# section 'db' is not used.
	mode = dbengine
	update every = 1
	storage tiers = 3

Why is the section 'db' not used ? How can I get netdata to respect /etc/netdata/netdata.conf?

Hi, @kopf. 1.33.1-2 is old, the latest stable is 1.38.1.

Hi @ilyam8 ,

Unfortunately 1.33.1-2 is the newest version available to be installed on openwrt. I see from github that 1.33.1 was released about a year ago, which is, for me at least, a tolerable age.

Has the method for configuring long-term metric retention changed in the intervening releases? Or, more importantly, can I find the documentation for 1.33.1 somewhere so I can look up the corresponding entry for https://learn.netdata.cloud/docs/deployment-in-production/metric-retention---database/change-how-long-netdata-stores-metrics ?


Yes, there was a huge amount of changes, and dbengine (metrics storing engine) was rewritten. You can use GitHub to read old documentation, see v1.33.1 tag dbengine readme.

Ah, thanks for the info! In that case it’s a pity that I can’t install the latest version, but hey.

I’ve added the options (memory mode and dbengine (multihost) disk space). Unfortunately the disk space config option is ignored, no matter whether I use “dbengine multihost disk space” or “dbengine disk space”:

# global netdata configuration

	update every = 2
	memory deduplication (ksm) = no
	debug log = syslog
	error log = syslog
	access log = none
	run as user = root
	memory mode = dbengine

	# option 'dbengine disk space' is not used.
	dbengine disk space = 64000

Any ideas?

Both of these options are supported in v1.33.1. Probably your Netdata compiled without dbengine support, check netdata -W buildinfo.

Bingo! Sorry, I was unaware that this was possible.

OK, time to have a look into compiling my own netdata for ARM. Thanks for your help!

Hi @kopf,

We have a ticket open for having the install script to support OpenWRT builds: https://github.com/netdata/netdata/issues/9517. Because of this discussion, Austin has raised a PR for the final bit to close it. That should make it a lot easier for you to get going.

That’s awesome news! Glad this message board thread wasn’t to no avail after all :slight_smile:

I’m following the github issue now - if I can help in any way, let me know.