Monitoring CPU Temps on RPiX

I had tried Netdata last year on a couple Raspberry Pi units and I remember being able to add CPU Temp to the dashboard. When I went back to try Netdata again on a new lab environment I cannot find a way to add CPU Temp. Can someone point me in the right direction?

Hello @Scott_Solomon and welcome into our community

This Linux machine sensors monitoring with Netdata | Learn Netdata might interests you. But this module is enabled out of the box. You should able to see the sensors charts

Tasos.

Edit: You have already installed the lm-sensors package right? This packet is pre-installed with the Agent.

Oh this seems to be an upstream issue with lm-sensors and RPis Support for Raspberry PI 4 · Issue #202 · lm-sensors/lm-sensors · GitHub, what RPi you use, what kernel version it runs and in what host OS?

Just used the link on the Nodes page to install/add to war room. Did not do anything separately to install a lm-sensor package.

1 Like

Running Pi4b 8GB RAM with Rasbperry Pi Lite 64-bit OS. Arc showing on the info page in Netdata is “5.15.32-v8+”

Can you try the followings?

  1. navigate to your netdata config folder

    <installed_path: (default) root folder (/)>/etc/netdata

  2. Disable the python sensors module

    ./edit-config python.d.conf, comment in the sensor module and change it’s value to no

  3. Enable the old charts sensors module

    ./edit-config charts.d.conf, add the line sensors=force

  4. Restart the Agent systemctl restart netdata

I do not see anywhere in the python.d.conf file that has a “sensors” area to edit… see full text of file below…


# netdata python.d.plugin configuration
#
# This file is in YaML format.
# Generally the format is:
#
# name: value
#

# Enable / disable the whole python.d.plugin (all its modules)
enabled: yes

# ----------------------------------------------------------------------
# Enable / Disable python.d.plugin modules
#default_run: yes
#
# If "default_run" = "yes" the default for all modules is enabled (yes).
# Setting any of these to "no" will disable it.
#
# If "default_run" = "no" the default for all modules is disabled (no).
# Setting any of these to "yes" will enable it.

# Enable / Disable explicit garbage collection (full collection run). Default is enabled.
gc_run: yes

# Garbage collection interval in seconds. Default is 300.
gc_interval: 300

# apache: yes

# apache_cache has been replaced by web_log
# adaptec_raid: yes
# alarms: yes
# am2320: yes
# anomalies: no
apache_cache: no
# beanstalk: yes
# bind_rndc: yes
# boinc: yes
# ceph: yes
chrony: no
# changefinder: no
# couchdb: yes
# dns_query_time: yes
# dnsdist: yes
# dockerd: yes
# dovecot: yes
# elasticsearch: yes
# energid: yes

# this is just an example
example: no

# exim: yes
# fail2ban: yes
# freeradius: yes
# gearman: yes
go_expvar: no

# gunicorn_log has been replaced by web_log
gunicorn_log: no
# haproxy: yes
# hddtemp: yes
# httpcheck: yes
hpssa: no
# icecast: yes
# ipfs: yes
# isc_dhcpd: yes
# litespeed: yes
logind: no
# megacli: yes
# memcached: yes
# mongodb: yes
# monit: yes
# mysql: yes
# nginx: yes
# nginx_plus: yes
# nvidia_smi: yes

# nginx_log has been replaced by web_log
nginx_log: no
# nsd: yes
# ntpd: yes
# openldap: yes
# oracledb: yes
# ovpn_status_log: yes
# phpfpm: yes
# portcheck: yes
# postfix: yes
# postgres: yes
# powerdns: yes
# proxysql: yes
# puppet: yes
# rabbitmq: yes
# redis: yes
# rethinkdbs: yes
# retroshare: yes
# riakkv: yes
# samba: yes
# sensors: yes
# smartd_log: yes
# spigotmc: yes
# springboot: yes
# squid: yes
# traefik: yes
# tomcat: yes
# tor: yes
# uwsgi: yes
# varnish: yes
# w1sensor: yes
# web_log: yes
# zscores: no

13th line from the bottom

Thanks… I’m an idiot!

nothing changed on the dashboard

Thanks… I’m an idiot!

Don’t be hard on yourself, you can easily miss that

You followed all of the steps in this Monitoring CPU Temps on RPiX - #6 by Tasos_Katsoulas commend and a sensors group of charts isn’t appear?

yes… that is correct

If you open a terminal

  1. open a shell as netdata user

    sudo -u netdata -s

  2. Navigate under the plugins directory
    cd /usr/libexec/netdata/plugins.d

  3. run manually the charts plugin
    ./charts.d.plugin

what do you see after a while?

There is no /opt/netdata directory

sry I have a different path prefix for my netdata installation, updated the path in the instructions above

I have a custom-plugins.d file in my /etc/netdata directory

  1. Navigate under the plugins directory
    cd /usr/libexec/netdata/plugins.d