Netdata Community

Rpi 4 failed to start kernel modules

I have tried to uninstall so i can reinstall and failed the uninstall procedure is not very obvious.

The method i used to install was:

bash <(curl -Ss https://my-netdata.io/kickstart.sh)

Some basics about my system if it helps:

pi@blackhole:/etc/netdata $ cat /proc/cpuinfo
processor       : 0
model name      : ARMv7 Processor rev 3 (v7l)
BogoMIPS        : 108.00
Features        : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xd08
CPU revision    : 3

processor       : 1
model name      : ARMv7 Processor rev 3 (v7l)
BogoMIPS        : 108.00
Features        : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xd08
CPU revision    : 3

processor       : 2
model name      : ARMv7 Processor rev 3 (v7l)
BogoMIPS        : 108.00
Features        : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xd08
CPU revision    : 3

processor       : 3
model name      : ARMv7 Processor rev 3 (v7l)
BogoMIPS        : 108.00
Features        : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant     : 0x0
CPU part        : 0xd08
CPU revision    : 3

Hardware        : BCM2711
Revision        : c03112
Serial          : 1000000095c25c9f
Model           : Raspberry Pi 4 Model B Rev 1.2
pi@blackhole:/etc/netdata $ uname -a
Linux blackhole.cfts.co 5.4.51-v7l+ #1333 SMP Mon Aug 10 16:51:40 BST 2020 armv7l GNU/Linux
cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION_ID="10"
VERSION="10 (buster)"
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"
root@blackhole:/etc/netdata#
pi@blackhole:/etc/netdata $ cat /etc/debian_version
10.6
pi@blackhole:/etc/netdata $ sudo systemctl status systemd-modules-load.service
    ● systemd-modules-load.service - Load Kernel Modules
       Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled)
       Active: active (exited) since Mon 2020-10-12 11:37:14 BST; 43min ago
         Docs: man:systemd-modules-load.service(8)
               man:modules-load.d(5)
      Process: 115 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS)
     Main PID: 115 (code=exited, status=0/SUCCESS)

Any advice, I’m not a Linux person i just dabble, I know enough to follow instructions do basic installs and a little trouble shooting and that it… sorry.

Hello @peter2cfu, except for

netdada reboot

All the other commands should work. For you restart Netdata manually you could use the following command sequence:

netdatacli shutdown-agent
netdata

Give few seconds between the execution of the first and second command to be sure that Netdata exited without problems.

We are glad that the sensors are working for you. :slight_smile:

1 Like

To recap:

Raspbian kernel (GNU/Linux 10 (buster)) Pi does not support the ebpf.plugin and is not needed to read the onboard sensors of the Raspberry pi

The command to run the NetData editor is:

sudo bash ./edit-config charts.d.conf

or just copy the .conf file you need to the /etc/netdata directory and edit with your favorite editor.

To reboot the NetData service use one of the following commands.

sudo service netdata restart
netdata reboot
sudo systemctl restart netdata

If all else fails reboot.

And now the temp sensors are working :slight_smile:

@peter2cfu after to edit the file, you need to restart Netdata, but it is not necessary to reboot the operate system, depending of your distribution, you can use systemctl command to send a restart, or you can combine the commands kill and netdata to restart it.

Without any doubt, the reboot will work :smiley: .

@peter2cfu after the cp command, you will need to edit it with some editor that you like, I forgot to say this, I am sorry for this

However seems this has no affect in regards to NetData operations, i’m starting to think either I am really missing something or this application not quite ready for Raspberry Pi…

Seems i’m in error a reboot sorted it out, if all else fails ‘reboot’ seems is not just for windows. :slight_smile:

I may have found the issues, it runs when I do this:

sudo bash ./edit-config charts.d.conf

see https://stackoverflow.com/questions/42393137/let-command-is-not-found-in-my-bash-script for a full explanation…

However seems this has no affect in regards to NetData operations, i’m starting to think either I am really missing something or this application not quite ready for Raspberry Pi…

@Thiago-Marques-0 thanks but seems that did not help, I had already manually copied this file over to this location thinking that may have been a possible issue.

pi@blackhole:/etc/netdata $ sudo cp -a /usr/lib/netdata/conf.d/charts.d.conf .
pi@blackhole:/etc/netdata $ sudo ./edit-config charts.d.conf
./edit-config: 10: /etc/profile.d/motd.sh: let: not found
./edit-config: 11: /etc/profile.d/motd.sh: arithmetic expression: expecting primary: "%60"
pi@blackhole:/etc/netdata $

charts.d.conf

# This is the configuration for charts.d.plugin

# Each of its collectors can read configuration eiher from this file
# or a NAME.conf file (where NAME is the collector name).
# The collector specific file has higher precedence.

# This file is a shell script too.

# -----------------------------------------------------------------------------

# number of seconds to run without restart
# after this time, charts.d.plugin will exit
# netdata will restart it, but a small gap
# will appear in the charts.d.plugin charts.
#restart_timeout=$[3600 * 4]

# when making iterations, charts.d can loop more frequently
# to prevent plugins missing iterations.
# this is a percentage relative to update_every to align its
# iterations.
# The minimum is 10%, the maximum 100%.
# So, if update_every is 1 second and time_divisor is 50,
# charts.d will iterate every 500ms.
# Charts will be called to collect data only if the time
# passed since the last time the collected data is equal or
# above their update_every.
#time_divisor=50

# -----------------------------------------------------------------------------

# the default enable/disable for all charts.d collectors
# the default is "yes"
# enable_all_charts="yes"

# BY DEFAULT ENABLED MODULES
# ap=yes
# apcupsd=yes
# libreswan=yes
# nut=yes
# opensips=yes

# -----------------------------------------------------------------------------
# THESE NEED TO BE SET TO "force" TO BE ENABLED

# Nothing useful.
# Just an example charts.d plugin you can use as a template.
# example=force
sensors = force

@peter2cfu this new error that you are seeing is happening because you did not have the command let installed on your system. You can do the following steps that are analogous to edit-config command:

# cd /etc/netdata
# cp -a /usr/lib/netdata/conf.d/charts.d.conf .

And after this you can follow the rest of the instructions.

So you can’t edit the charts.d.conf and make the adjustments that are described in the blog post. Can you please send us the logs?

@OdysLam Correct the editor does not startup, just the errors as shown.

I don’t have experience with that particular project. Perhaps @joel can help?

But, when you do run the ./edit-config, it should open-up an editor. It doesn’t?

@OdysLam is it possible to point me in the right direction, googling has not helped and documentation on the NETDATA site seems to be out of date?
https://learn.netdata.cloud/guides/monitor/pi-hole-raspberry-pi

pi@blackhole:~ $ cd /etc/netdata
pi@blackhole:/etc/netdata $ sudo ./edit-config charts.d.conf
./edit-config: 10: /etc/profile.d/motd.sh: let: not found
./edit-config: 11: /etc/profile.d/motd.sh: arithmetic expression: expecting primary: "%60"

I did find this but its quite old 2016: https://github.com/netdata/netdata/issues/858, which seems to suggest that this cannot be done on a raspberry pi.

You can monitor the whole system as usual, you just can’t use the ebpf module which is highly specialized.

You can read more about ebpf at our documentation.

Best,
odysseas

àhh ok, so I can’t monitor the sensors then or is there another way?

Hello @peter2cfu ,

This error is happening, because the kernel on your distribution does not allow you to use ebpf.plugin. The distribution team disabled the feature KPROBE_ON_FTRACE on your distribution.

Netdata will work normally on your system, the unique exception will be this plugin.

Best regards!

@OdysLam
When I reinstall I still get the same kernel error:

--- eBPF Kernel Collector ---
[/tmp/netdata-kickstart-Igc4xxaShH/netdata-v1.25.0-160-g22419f82]# ./packaging/check-kernel-config.sh
Missing Kernel Config: KPROBES_ON_FTRACE
FAILED

Warning: Kernel unsupported or missing required config (eBPF may not work on your system)
--- Installing eBPF plugin ---

This is a problem as I need to get access to the temp sensors, very critical with SBC’s.
Other than that all other critical systems seem to install well and is working,

@OdysLam
I have managed to uninstall by:

sudo /usr/libexec/netdata/netdata-uninstaller.sh --force --yes

I found a useful article on github for uninstalling and that seemed to work: https://github.com/netdata/netdata/issues/2938, the netdata.cloud site uninstall instructions I could not get to work at all, I most likely did not understand: https://learn.netdata.cloud/docs/agent/packaging/installer/uninstall

Welcome to the community!

Can you please elaborate on it's not very obvious. What happens when you run the uninstaller?

Also, why did you want to uninstall and then install again? If you run the script again, it will update Netdata to the latest stable release.