Netdata agent fails to run on pfSense 2.70

Hi all,

New user of netdata here, loving it so far. I’ve followed through guide to the T here:

and was able to install netdata successfully. However agent cannot run and you’ll see the error when i try to run it manually in screenshot: Shared object “” not found, required by “netdata”

also /var/log/netdata/ is empty so no logs to help me out. I’m out of ideas as I tried FreeBSD version of install with no luck. TIA

Hi @meshringer ,

Sorry you’re facing this issue but has mentioned the pfSense document you shared isn’t maintained by Netdata team.

I was trying to do a google search and found a, sort of, similar issue reported on reddit Reddit - Dive into anything
Could you take a look and see if helps? Other could be also to ask for help on PFSENSE subreddit.

Hope you are able to get help on figuring this out.


Thanks @hugo - yes i’ve gone through the same exact scenario. In fact I was able to bypass the pkg upgrade required by locking pkg. This allowed me to proceed the install without upgrading pkg. Of course it broke later on and complained with the same .so.30 error when trying to run netdata. Looks like we’re at a dead-end… or perhaps is there a way to get a version of the agent not requiring the latest pkg?

Let me ping @Austin_Hemmelgarn or @Tasos_Katsoulas to see if they can help.

Hello @meshringer and welcome to our community. If I may, did this stage in our docs (Install Netdata on pfSense CE | Learn Netdata) run smoothly? I mean, you didn’t receive any error, right?


Hi @Tasos_Katsoulas - Originally no, when running pkg install -y pkgconf bash e2fsprogs-libuuid libuv nano

it tells me I need to upgrade pkg. When i do that, it breaks pkg and can no longer move forward. See below:

You may need to manually remove /usr/local/etc/pkg.conf if it is no longer needed. Shared object “” not found, required by “pkg”

so because pkg is broken I can’t proceed with install.

Luckily I have cached version of previous pkg to restore to 1.19.1_2:
pkg-static add -f /var/cache/pkg/pkg-1.19.1_2.pkg

After unbreaking pkg, what I then tried was lock pkg ‘pkg lock pkg’ to prevent the update requirements. which then successfully installs all pre-req packages and even installs netdata. But netdata service cannot start and netdata does not start, as it complains of similar missing object. I’m not an expert in libraries of linux, but it seems netdata needs the latest version of pkg, however pfsense doesn’t like it.

Hope that helps.