netdata-kickstart: /tmp unwritable(?), netdata-claim: curl doesn't work

I just added 9 nodes in 2 warrooms and I’m impressed with netdata so far.

I had two problems adding one node (Azure Ubuntu 20.04.4 VM. Other Azure Ubuntu VM’s with this version worked, though I wonder if this was an older one that was originally Ubuntu 16.):

  1. The kickstart script couldn’t create directories in /tmp, or something, so I did TMPDIR=/root/tmp /tmp/ ... and it got past this error:
[/tmp/netdata-kickstart-pdusNtbsQs]# curl --fail -q -sSL --connect-timeout 10 --retry 3 
--output /tmp/netdata-kickstart-pdusNtbsQs/netdata-repo-edge_1-1_all.deb                      
curl: (23) Failure writing output to destination                                                                                                      
  1. Second problem I encountered: Claiming failed with an “Unknown HTTP error message” On a whim, I did mv /snap/bin/curl /snap/bin/curl-disabled and it used wget instead and worked.
Netdata user: netdata
Connection attempt 1 successful
Failed to claim node with the following error message:"Unknown HTTP error message"                                                                    

(Not sure if this is relevant: I first tried with Ubuntu 18, and sysctl fs.protected_regular showing 0.
Then I upgraded to Ubuntu 20.04.4 and it shows fs.protected_regular = 2 and still had the problem until my workarounds above.)

To clarify, I’m good now – I just thought I’d pass on what I learned.

Hi @jaredthirsk ! Thank you for your report!

The first one is really weird… Was the problem with the temp directory reproducable ?

For the second problem, there was a recent fix with wget/curl in the claiming procedure (fix: claiming with wget by ilyam8 · Pull Request #12163 · netdata/netdata · GitHub) but I assume you already use through kickstart a recent enough version.

If by any chance you can reproduce these, we would be happy to try and fix!!