Offline installation preparation script fails

Downloading offline installation files using the scripts in the documentation fails

I have been unable to download the offline installation files using either the wget or curl scripts provided in the documentation.

Preparing the offline installation source

I always received “No such file or directory” errors for all of the various offline install files. This problem started when version 1.44.3 was released. I have tried at least 10 different, since the v1.44.3 release and always receive the same error messages.

Have the files the script is trying to download not been uploaded to github, or have the location where they’re stored been changed and the script not been updated?

This issue has been also reported on our Discord server on this thread and seems to be related.

There were two separate issues identified:

  1. We’re not handling the case in the script of not actually fetching any of the static build archives (and thus the validation step is running incorrectly).
  2. We’re not handling the fact that there exist braindead firewalls that block HTTP HEAD requests (which we use to check if the files exist on the server before downloading them so that we can differentiate the file not being there (which is usually not an issue) from the download of the file failing for some other reason).

There is this PR open to fix this situation.