Remove and reconnect a node - invalid room ID

When reconnecting node in this case Ubuntu I run to error when running claiming script after I deleted the cloud.d/ as it is in manual .

sudo -token=TOKEN -rooms=ROOM1,ROOM2 -url= -id=$(uuidgen)
Token: ****************
Base URL:
Id: 20680842-a4c2-4de3-b2f6-eacf6e6ef5a8
Rooms: ROOM1,ROOM2
Hostname: ubuntu
Netdata user: netdata
Connection attempt 1 successful
Failed to claim node with the following error message:"invalid room id"

Hi @Viktor_Svitek !

Did you actually enter the strings “ROOM1,ROOM2” in your command? You need to get the proper token and room GUIDs from See the grayed out parts below.

Hi Christopher,

Yes ~I have added those strings, tried it couple of times but seems that there must be the other issue maybe it is related to this. When I restarted pc I did get an system error and this is the error _usr_libexec_netdata_plugins.d_ebpf.plugin.0.crash I have found in other discussion that this was issue was removed by UBUNTU 18.04. Mine is 20.04.

The crash shouldn’t be related, I asked our eBPF guru to step in.

To further debug claiming, please send the exact command with the actual room ids you used to, so I can ask someone to take a look at what’s happening.

Hello Viktor,

I was talking with @Christopher_Akritid1 about this, please, can you give us the kernel you are using running the command uname -a?

Ubuntu has Linux kernel with a lot of patches, sometimes they bring features merged in recent kernels for old versions and this creates problems, for example, months ago an user reported that eBPF.plugin was crashing the whole system, but this could not happen, because eBPF runs inside a VM. This vulnerability was an explored by some hackers.

If it is possible, please, also share the core dump. This week I am working to fix possible bugs with eBPF.plugin.

Best regards,


HI Thiago,

Thanks for support. This is my kernel Im using.

Linux ubuntu 5.4.0-88-generic #99-Ubuntu SMP Thu Sep 23 17:29:00 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

I would like to share the dump file but I dont know how as even Im root user I cannot do anything with the file.

Thank you for your answer.

A last question, did you install netdata using DEB packages?

Today I will work exclusively with Debian/Ubuntu and I hope to have the fix at the end of the day.

HI Thiago,

No I didn`t.

Thank you for the information!

Firstly, sorry for delay, but we were working to improve eBPF and fix ancient bugs.

I made a last PR addressing bugs today, the PR New eBPF and libbpf releases by thiagoftsm · Pull Request #11680 · netdata/netdata · GitHub, I tested it with two different kernels released by Ubuntu and I did not have more crashes. I expect that when the PR is merged you won’t have more core dumps on your system.

Best regards!

PR was merged, so next nightly won’t have more the reported problem.

Thank you for your report!

Awesome! @Viktor_Svitek please let us know after you get today’s nightly, if that fixes your issue.

Hi Christopher,

Sorry for later answer. I have the connection to monitoring system fixed (this was done by right done settings of the rooms) but I still get an error when starting the system.

Hello Viktor,

Today I used the following environments to check possible problems with eBPF running on Ubuntu:

Dist kernel
Ubuntu 18.04 4.15.0-159
Ubuntu 18.04 5.4.0-89
Ubuntu 20.04 5.4.0-89

I compiled the latest netdata on all environments, and I did not observe problems neither when I started netdata on terminal, nor when I restart the VM and sytemd started Netdata.

When you say “I still get an error when starting the system.”, does this error have relationship with eBPF.plugin?

I ran netdata v1.31.0-450, what is your netdata version (netdata -V)?

Best regards,