Remove "Netdata Monitoring" from dashboard.


I’m working on a light-weight version of netdata monitoring for a machine’s OS, i managed to remove almost everything i did not need by editing “netdata.conf”, but the only thing i cannot find where to disable is the whole section of “Netdata Monitoring”.

Please help! <3 much love, Yves.

Hi @Yves_Halimi welcome!!

Can you try (in a recent netdata version) to add this to the config:

   netdata monitoring = no


1 Like

I tried, what happened was that some of the sub-content of “Netdata Monitoring” were removed and some still there.

thank you some much for the warm welcoming and the fast answer! <3

Hmm, yes, I was kinda expecting that…

It seems we still need to respect this setting from other parts of the code as well in order to completely remove the section. Sadly at the moment there’s not something we can do in your case, besides of waiting for an update. We’ll try and implement this as soon as possible.


1 Like

It did improve a bit so i’m happy with the solution.
May i ask another question regarding the dashboard?

I’ve been using “go.d” prometheus plug-in to save costume-made metrics with python-prometheus library.
My problem is that in addition to the metrics i created, i am getting “python gc” , “python info”, “process”, “collection” charts for each different endpoint of prometheus i am scraping with netdata agent.

How can i disable these charts? is there another configuration?

(I can open a different post if needed)

That is implemented. @Yves_Halimi you are on 1.36.0-104, the latest is 1.37.0-24. You need to update to v1.37.0+. Setting “netdata monitoring” to “no” completely removes the section for me.

Yes, you can filter out unwanted metrics by using selector.

1 Like

@ilyam8 Hello! thank you for the answer.

I tried to get rid of the “collector” chart with DENY/ALLOW inside prometheus.conf, but i did not succeed.

i tried both the chart identifier and the chart name, but both did not work for me:

@Yves_Halimi are you using nightly releases?

  • The latest nightly release has no “collect_statistics”.
  • Selector (allow/deny): use metric names as you see them in http://IP:PORT/metrics. Also, you need to use wildcards if you want to filter not specific metrics (e.g use process* not process). See examples.
1 Like

OMG i could kiss you right now <3 @ilyam8

I managed to use the selector now and it works!!


I’m so satisfied with my version right now!

Little last thing i was wondering about, in the dashboard itself, before every scraped endpoint job name there is the word “prometheus” prefix. is there a way to change this prefix or remove it at all?

THANK YOU SO MUCH - i was battling my head with it for so long now!

1 Like

Unfortunately no, it’s not possible right now.

1 Like