Netdata Community

Switch to db engine fails

Hi,

I’ve just installed Netdata for the first time and found that if I want longer logging periode, I could enable dbengine as described in the Docs. But as soon as I configure “memory mode = dbengine” and restart these service it fails.

Letme know what kindof logs you need.

Thanks

System is Debian 8

Hello @TrackMeDown,

Welcome to our community.

How did you install your Netdata? By default, Netdata uses dbengine, so it is not necessary to change the memory mode.

Please, can you copy the error that you are having to restart Netdata?

Best regards!

Hi @Thiago_Marques_0, thanks for your help so far.

I’ve reinstalled the VPS completely and installed Netdata again with the same result.
The only change I did after running the kickstareter.sh was to edit the config using the edit-config

after restarting the service it failed and I’ve checked the error.log (that’s ok?)

Does this help ?
I must say that this VPS might not be the best really, it’s still debian 8 with no option to upgrade to an recent version.
I’ve ran the kickstart.sh on my Raspberry and dbengine seems to run fine, so maybe it’s a restriction by the OS or VPS system ?

Any help is much appreciated

You’re missing the dependencies required to compile dbengine support in the agent binary. Maybe try running kickstart.sh as root. Another idea would be to run sudo packaging/installer/install-required-packages.sh netdata. Depending on your platform, it may be necessary to install third party repositories for some missing packages. You should check the documentation here.

Thanks I’ll try that and comment back if it worked or not.

Hi @Markos_Fountoulakis,

I’ve installed the dependencies, cloned it and ran the installer. I’ve also tried “CC=gcc ./netdata-installer.sh”

The result is the same. I saw that during the install the following error pops up. Not sure what it means:

Everything else came back with a green OK.

Any advise ?

Also, I saw that Netdata thinks I did not want automatic updates:


but I did not use the --no-updates flag. Any advise on this ?

Can you run ./configure and share the output in full (in text format)?

Thanks @Markos_Fountoulakis, like this?

EDIT: Moderator removed pastebin that led to 404.

Hello @TrackMeDown,

First I apologize the delay, but I am on vacation, please, take a look at these lines:

checking for LZ4_compress_default in -llz4... no
checking for ZLIB... yes
checking if zlib should be used... yes
checking for UUID... yes
checking for SHA256_Init in -lcrypto... yes
checking for X509_VERIFY_PARAM_set1_host in -lcrypto... no
configure: WARNING: DISABLING SSL HOSTNAME VALIDATION BECAUSE IT IS NOT AVAILABLE ON THIS SYSTEM.
checking for JSON... yes
checking for json_object_get_type in -ljson-c... yes
checking for JudyLIns in -lJudy... yes
checking if netdata dbengine should be used... no

As you can see the dbegine was not not compiled, because the lz4 is not installed on your system, please, install this package, and you will be able to use dbengine.

Best regards!

I forgot to give the source of the information, this is the line that is failing.

Best regards!

If I’m not mistaken, that package is not available on Debian 8. However I’ve found liblz4-1 which was already installed.

https://packages.debian.org/search?keywords=lz4

@Thiago_Marques_0 tbh, I do not expect immediate response times ! Enjoy your holiday.

2 Likes

What you need is liblz4-dev. Keep in mind that Debian 8 is End-Of-Life and the problems are going to keep increasing.

1 Like

Thanks, I’m aware about this but the hoster does not support newer version yet.
I’m going to switch hoster soon so I’m not sure how much sense it makes to keep on troubleshooting this.

liblz4-dev is already installed too.

The Server got replaced. Now this is fixed.