Aborted Installation

Hi there,

I’m new on NetData and I can not find a solution for my problem, I’m installing on CentOS 7.9, I had installed with the automatic script, when I grep the version says CUSTOM, and keep not connecting to the cloud, when I tried re install I got this error:

— Checking for existing installations of Netdata… —
ABORTED Found an existing netdata install at /, but the install type is ‘custom’, which is not supported, refusing to proceed.

And I don’t know how to make things working.

Looking forward to any kind help.

My best regards,


Hello @Leandro_Aguiar and welcome into our community,

Could you share your netdata -W buildinfo ?


Hey Tasos,
many thanks for your reply, maybe looks like stupid this question, but, how can I get out this info on CentOS ?

Many thanks,


It’s a valid question don’t worry, there are two ways to interact with netdata via command line. The netdata daemon and the netdata cli.

Both of them are under:

/usr/sbin/{netdata, netdatacli} (for native builds, compiled from source installations)
`/opt/netdata/bin/{netdata, netdatacli} (for static builds)

In the first case you can just execute the command user@host $ netdata -W buildinfo (because these executables 99% of the cases are exported in your $PATH)

In the second case, if you have not export this path (opt/netdata/bin/), navigate yourself inside the repo and run the same command there.

To understand in which situation you are try the which | whereis netdata commands

Many thanks!
Here is the output:

Version: netdata v1.34.1
Configure options:  '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--program-prefix=' '--disable-dependency-tracking' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/var/lib' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--enable-plugin-freeipmi' '--with-bundled-protobuf' '--with-zlib' '--with-math' '--with-user=netdata' 'build_alias=x86_64-redhat-linux-gnu' 'host_alias=x86_64-redhat-linux-gnu' 'CFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1  -m64 -mtune=generic' 'LDFLAGS=-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld' 'CXXFLAGS=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1  -m64 -mtune=generic' 'PKG_CONFIG_PATH=:/usr/lib64/pkgconfig:/usr/share/pkgconfig'
Install type: custom
    dbengine:                   YES
    Native HTTPS:               YES
    Netdata Cloud:              YES
    ACLK Next Generation:       YES
    ACLK-NG New Cloud Protocol: YES
    ACLK Legacy:                NO
    TLS Host Verification:      YES
    Machine Learning:           YES
    Stream Compression:         NO
    protobuf:                YES (bundled)
    jemalloc:                NO
    JSON-C:                  YES
    libcap:                  YES
    libcrypto:               YES
    libm:                    YES
    tcalloc:                 NO
    zlib:                    YES
    apps:                    YES
    cgroup Network Tracking: YES
    CUPS:                    NO
    EBPF:                    NO
    IPMI:                    YES
    NFACCT:                  NO
    perf:                    YES
    slabinfo:                YES
    Xen:                     NO
    Xen VBD Error Tracking:  NO
    AWS Kinesis:             NO
    GCP PubSub:              NO
    MongoDB:                 NO
    Prometheus Remote Write: YES

Thank you and sorry for the delay. Can we double down on which automatic script you used to install netdata? please reference any docs/blogs you found and the instructions you followed.

I follow this page:

Please follow netdata/REINSTALL.md at master · netdata/netdata · GitHub this section to perform a clean reinstall. This info is not yet in our docs (learn.netdata.cloud) but it will guide you to overcome your issue.

Good morning Tasos!
Still not working, please have a look on the attached file with the output.

Looking forward to your kindly reply.

Did you tried it with sudo (with a sudoer user)? I see that the uninstaller is failing due to: permissions not granted.

I’m as root on the server and I had tried now with:
sudo wget -O /tmp/netdata-kickstart.sh https://my-netdata.io/kickstart.sh && sh /tmp/netdata-kickstart.sh --reinstall-clean

and getting the same error.

Ok let’s split the processes, run the Uninstall Netdata | Learn Netdata on it’s own and let me know if everything went smoothly.

If no error presented and the commands:

  • $ rpm -qa | grep netdata
  • $whereis netdata

return nothing

proceed with our kickstart installer Install Netdata with kickstart.sh | Learn Netdata

where I can grab the NETDATA_PREFIX value?

This question is like the chicken with the egg problem :slight_smile: . This info is under the file NETDATA_PREFIX/etc/netdata/.environment. Try
$ cat /etc/netdata/.environment

cat: /etc/netdata/.environment: No such file or directory

netdata]# dir
charts.d conf.d health.d netdata.conf python.d statsd.d

Ok let’s double down on where is your config directory. Use:

curl -sq "http://localhost:19999/netdata.conf" | grep -m1 "config directory"

Navigate in this directory and use dir -a or ls -la

. .bash_history.cpanel_ticket.94386976 cpanel3-skel netdata-uninstaller.sh.1
… .bash_history.cpanel_ticket.94390640 cpanel-install.log .newrelic
.bash_history .bash_history.cpanel_ticket.94393059 cpanel_profile original-ks.cfg
.bash_history.cpanel_ticket.93774817 .bash_history.cpanel_ticket.94398984 .cpanm .pearrc
.bash_history.cpanel_ticket.94025233 .bash_history.cpanel_ticket.94401632 .cshrc perl5
.bash_history.cpanel_ticket.94135035 .bash_history.cpanel_ticket.94405378 .elinks .pki
.bash_history.cpanel_ticket.94298683 .bash_history.cpanel_ticket.94417170 .gem .razor
.bash_history.cpanel_ticket.94337791 .bash_history.cpanel_ticket.94430374 .gnupg .rnd
.bash_history.cpanel_ticket.94343264 .bash_history.cpanel_ticket.94435154 .HttpRequest .spamassassin
.bash_history.cpanel_ticket.94344585 .bash_history.cpanel_ticket.94444059 kernelcare-latest-7.rpm .ssh
.bash_history.cpanel_ticket.94347682 .bash_history.cpanel_ticket.94444809 latest .tcshrc
.bash_history.cpanel_ticket.94351353 .bash_history.cpanel_ticket.94448243 .lesshst tmp
.bash_history.cpanel_ticket.94383865 .bash_logout .libnet-openssh-perl userlist
.bash_history.cpanel_ticket.94385293 .bash_profile .MirrorSearch .viminfo
.bash_history.cpanel_ticket.94385333 .bashrc .my.cnf .wp-toolkit-identifier
.bash_history.cpanel_ticket.94386117 .cpanel netdata-uninstaller.sh

here is the output

Wait a second, this output makes no sense.

This curl -sq "http://localhost:19999/netdata.conf" | grep -m1 "config directory" command will print you something like this

	# config directory = /etc/netdata

And I suggested you to navigate under this directory /etc/netdata or w/e it prints you and run dir -a or ls -la

Is it still your output (after you double check the above)?

the out is this:

[root@xxxxxx ~]# curl -sq “http://localhost:19999/netdata.conf” | grep -m1 “config directory”
[root@xxxxxx ~]#

[root@xxxxxx ~]# dir /etc/netdata
charts.d conf.d health.d netdata.conf python.d statsd.d