Netdata Community

Changing size of key system metrics

Sorry to be so full of questions - Is there a way to change the size of the key system metrics? What I mean is that looking at used swap, net inbound, net outbound and used ram the information is not very easy to see. I’ve attached a screenshot.

!1601913961980-screenshot_2020-10-05_10-53-23.png

@Jacek-Kolasa You’re correct, no changes should be made in Netdata. I didn’t have the problem until I upgraded to Ubuntu 20.04 from 18.04 so something had been changed in the Ubuntu version of Firefox which I use.

@chris-pollock I wasn’t aware that the problem like that can exist, so thanks for your research! I don’t see if this can be fixed on our side, because perhaps some users would like to zoom the text on some cases, please correct me if you think otherwise :slight_smile:

Thank you to share this with us @chris-pollock !

@chris-pollock I asked on the Firefox help page - got a quick reply that fixed the issue. I’ll share it here

Your Firefox screenshot shows that you have set a larger text for that part. The numbers are placed at a fixed position and the label text above it doesn't fit on one line and wraps and covers the numbers. This can either be that a larger font is used or that you have set a larger default font size.

If you have made changes to Advanced font-size settings like increasing the minimum/default font-size then try the Default font-size setting "16" and the Minimum font-size setting "none" in case the current setting is causing the problem.

    Options/Preferences -> General: Fonts & Colors -> Advanced -> Minimum Font Size (none) 

Make sure you allow pages to choose their own fonts.

    Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above" 

It is better not to increase the minimum font-size, but to use the builtin Firefox Zoom feature.

    Options/Preferences -> General -> Language and Appearance -> Zoom 

!

@chris-pollock I just now tested this with Google Chrome and Brave browser. Both look correct as in the screenshots below so the issue is with Firefox it seems.
Google Chrome
!

Brave
!


I’ll have to take a look at setting in Firefox to see if I can figure out what has changed since it looked fine in Ubuntu 18.04.

Running Ubuntu 20.04.1 LTS browser is
firefox:
Installed: 81.0+build2-0ubuntu0.20.04.1
Candidate: 81.0+build2-0ubuntu0.20.04.1

@chris-pollock can you please let us know what browser version/os are you using?

@chris-pollock thank you for the bigger screenshot, I am waiting for an answer from the front-end team, as soon I have it I will give to you. Unfortunately I do not have enough knowledge on front-end to answer you right now.

@Thiago-Marques-0 Here’s a bit larger screenshot

!

@chris-pollock no problem, write the number of questions that you need to understand Netdata we are here to help you.

I never saw on dashaboard any configuration related to this, it is possible that we will need a feature request for this.

I asked our frontend team about this and when I have a proper answer I will give to you, it is also possible they will come here to answer us.

Best regards!