Netdata Community

Does Netdata support R7000 with FreshTomato?

Hey NetData team,

I’ve recently started using your monitoring product and absolutely love it! I’ve mostly focused on smaller devices that are generally more difficult to monitor, starting with Raspberry Pi and now moving over to my router. Well, at least trying to anyways.

I run FreshTomato firmware on my R7000 and have been trying to get NetData up and running, but have not had any luck in getting it to work. I’ve tried two methods so far and have had different issues with each one.

  1. Using OPKG and Entware-NG
    Following instructions from here: DD-WRT on Linksys WRT1900ACS v2 – Entware - Tech Blog
    DD-WRT on Linksys WRT1900ACS v2 – Real-time monitoring with netdata - Tech Blog

This seems to work as far as the installation goes. I don’t get any error messages and when I do a check using “opkg files netdata”, it shows that the files themselves have been installed.

However, after installation the agent doesn’t seem to actually start up. When I try to bring up the page I receive a “This site can’t be reached” error in Chrome.

I’m not really sure what I can do to see if Netdata is actually running or not?

  1. Trying to install manually. I downloaded the kickstart.sh file and tried to run it with bash. However, when I do that, I get an error saying that it can not find a suitable temporary directory to use. It says that TMPDIR is not defined and errors out at that point. I went ahead and defined TMPDIR and checked “env” to make sure that it was correctly placed, but the script still insists that it’s not defined.

At this point, I’m not sure what else I can do to troubleshoot. Your help would be much appreciated.

Environment

Netgear R7000 router

Freshtomato firmware
https://freshtomato.org/

Entware NG
https://wiki.dd-wrt.com/wiki/index.php/Installing_Entware

Problem/Question

Netdata either will not run or will not install. See above for details.

What I expected to happen

Expecting Netdata to install and run and provide me pretty charts :slight_smile:

Thanks for any help you can provide!

Hi ! Welcome to the Netdata community!

This is very interesting! I haven’t kept up with alternative firmwares on routers (running an old tomato version on one of mine), so things seem to have progressed a lot!

I would need to catch up with Entware NG, but it seems Netdata is packed from a third-party for this. So I’m not really sure how packages are installed and where, and how they are started up. Can you check if there is an /opt/etc/init.d/netdata script maybe? If yes, can you try to run it?

Thanks!

1 Like