Netdata installation ABORTED - Static binary checksum validation failed.

I have been trying to install Netdata on one of our Oracle Linux 6 servers since last week, but it keeps failing with following error:

“ABORTED Static binary checksum validation failed. Usually this is a result of an older copy of the file being cached somewhere upstream and can be resolved by retrying in an hour.”

I have re-tried several times on several days and still the issue persists.

Note that I have successfully installed Netdata on several of our other OL6 servers previously - it is only this one that is now giving the error.

Further details as follows:
OS: Oracle Linux Server 6.10
Latest installation script I tried with:

wget -O /tmp/ && sh /tmp/ --claim-token xxD9ON_IJGLKfSQCkW-cKujBmcZMXR2Is3bMJbaFwP01PPRjco6VGJrXqKOzQ0SCJV8m0BPD2n4-4KueYYvqUPmVm1gczEYXsfggs46_YpbpkMxN3k100Y_oERrt0bpmfyecZiQ --claim-rooms 9b9b5029-e92b-4d80-b0b1-2956dc9ab706 --claim-url


curl > /tmp/ && sh /tmp/ --claim-token xxD9ON_IJGLKfSQCkW-cKujBmcZMXR2Is3bMJbaFwP01PPRjco6VGJrXqKOzQ0SCJV8m0BPD2n4-4KueYYvqUPmVm1gczEYXsfggs46_YpbpkMxN3k100Y_oERrt0bpmfyecZiQ --claim-rooms 9b9b5029-e92b-4d80-b0b1-2956dc9ab706 --claim-url

Any help will be greatly appreciated, thanks!

I’m unable to reproduce this locally, and manually verifying the checksums shows no issues.

Most likely, either something is really strange about internet access for that one particular system, or you’re seeing symptoms of a hardware issue with that system (such as data corruption on disk or bad RAM).

Issues with internet access are probably the more likely of the two possibilities. Can you share some info about how the affected system connects to the internet such as the hosting provider or ISP and the geographic location (coarse info just indicating what country is good enough here).

Good day and thank you for your response.

The ISP is Vodacom and we are in South Africa. If you can give me an address I could send you the trace route results from the server if you would like.

I reviewed the internet settings on the server and I cannot see anything out of the ordinary, it uses the same configuration and ISP as our other servers where I could successfully install Netdata.

Would appreciate any further advice.

Many thanks.





OK, the fact that all the other servers are on the same link and not seeing issues means it is, indeed, probably not the link itself (unless you have some special local network configuration for the affected system, which I doubt given what you’ve said so far).

Could you try adding --stable-channel to the options you’re passing to the installer? That will result in it installing the latest stable release instead of a nightly build like it defaults to, but it will also mean it’s pulling from a different location (our release page on GitHub, instead of the GCS bucket we use for nightly builds). If that also fails in the same way, then it’s probably a hardware problem or at-rest data corruption somewhere on-disk on the affected system. If it works then at least you have a working install of Netdata.

Thank you, I tried with the --stable-channel option, but it still fails in the same way.

This server is of a different make and with different hardware specs from the others, so I believe the issue might be hardware related. Fortunately, it is not critical to run Netdata on this server, we will just go without it.

Many thanks for your assistance, much appreciated.