Netdata Community

Node claimed but "Sorry we cannot find your Agent in the Netdata Cloud visited nodes"

Data looks great in war rooms, however email and Slack alerts contain a link which returns:

Sorry we cannot find your Agent in the Netdata Cloud visited nodes. To continue please claim your node in the Netdata Cloud

Not able to find this error message with forum search or web search.

Following the troubleshooting steps:

  • cloud-enabled is true
  • cloud-available is true
  • No cloudy errors during runtime in Netdata error.log
  • No ACLK errors in grep’d error.log
  • agent-claimed is true
  • aclk-available is true

The environment is a VPS (kvm) without Docker or k8s, running Ubuntu 20.04. Email received in Gmail web app and link clicked with Firefox latest stable. Slack app is latest stable. Links in alerts for other nodes work as expected. If unauthenticated, or authenticated with Netdata Cloud in another tab, same result.

Please can you advise next troubleshooting steps? Thanks

The error seems to me to be misleading. In the cloud, check the left navigation bar for the list of visited nodes and see if your node appears there (it doesn’t need to be claimed to appear there). It’s probably not there, so we need to access the node’s user interface, while logged in to the cloud, so it can be added.

  • Access your node’s dashboard (not the cloud, something like localhost:19999).
  • Ensure you’re signed in to the cloud, while viewing your node’s dashboard (i.e. no Sign In prompt on the UI). - If you’re not signed in, click the button and ensure you have viewed the dashboard again while signed in.
  • Verify that the node now appears in the list of visited nodes

If it still doesn’t work, it’s a bug and we need to investigate further.

Email notifications from the cloud do not have this issue and they are sent for claimed nodes.
Notifications sent from the agent itself have a link that’s supposed to get you to the agent’s dashboard, not to the cloud. Signing in to the cloud in these cases is required as the opt in that allows us to hold the information and help with the redirect. The agents do not need to be claimed for this process to work, you just need to be logged in when you view a node, so that the info is saved to the cloud to enable the redirect.

Thanks Christopher,

check the left navigation bar for the list of visited nodes and see if your node appears there

It’s not in the list of visited nodes as you predicted

Ensure you’re signed in to the cloud, while viewing your node’s dashboard (i.e. no Sign In prompt on the UI). - If you’re not signed in, click the button and ensure you have viewed the dashboard again while signed in.

I click Sign In and get taken to the logged-in cloud dashboard, but when I go back to the node it still says Sign In. Seems to be working though

Verify that the node now appears in the list of visited nodes

Yes the server appears in the list now

Following the alert links then generates this message:

We found your Agent urls but they don’t seem to be responding. Please select url manually if you wish to redirect.

Understandable as its a private IP only accessible over VPN, and the manually selected URL works as expected

Email notifications from the cloud do not have this issue and they are sent for claimed nodes. Notifications sent from the agent itself have a link that’s supposed to get you to the agent’s dashboard

I see, yes we’ve recently outsourced part of our infrastructure and the external team are receiving alerts with links that only I can view (because of the firewall rules) despite being granted access to the cloud dashboard. In that case I’ll recommend that they enable cloud alerts instead. Looking forward to the webhooks feature by the way!

Thanks again for your help