opensearch (elasticsearch alternative) does not appear automatically.

opensearch does not appear automatically. Is it correct that it doesn’t appear automatically?

Hi, @COBAY. Two questions:

  • Does opensearch have the same API as ES? See Used Endpoints.
  • What port is the application listening on? ES is 9200.

Ok, I started an opensearch docker container. I see these differences:

  • https
  • basic auth is needed, default user/password is admin/admin.

The following worked for me:

  - name: local
    tls_skip_verify: yes
    username: admin
    password: admin

Added that job to the default elasticsearch config in go.d/#1140.

1 Like

I’ve just disabled security. It’ okay.

echo “ true” | sudo tee -a /etc/opensearch/opensearch.yml