Netdata Community

Windows Client not shown

Hey there,

just set up my NetData Server (Debian 11) and want to monitor some of my Windows Server 2019 machines.

I´ve installed the exporter on the Windows server (also be able to browser http://IP:9182/metrics and get data) and updated the NetData Config like here.

My problem is I can´t see the Server anywhere in NetData.

Any help? Thanks!

Debug informations ("./go.d.plugin -d -m wmi")

[ DEBUG ] main[main] main.go:111 plugin: name=go.d, version=v0.30.0
[ DEBUG ] main[main] main.go:113 current user: name=root, uid=0
[ INFO  ] main[main] agent.go:106 instance is started
[ INFO  ] main[main] setup.go:39 loading config file
[ INFO  ] main[main] setup.go:47 looking for 'go.d.conf' in [/etc/netdata /usr/lib/netdata/conf.d]
[ INFO  ] main[main] setup.go:54 found '/usr/lib/netdata/conf.d/go.d.conf
[ INFO  ] main[main] setup.go:61 config successfully loaded
[ INFO  ] main[main] agent.go:110 using config: enabled 'true', default_run 'true', max_procs '0'
[ INFO  ] main[main] setup.go:66 loading modules
[ INFO  ] main[main] setup.go:85 enabled/registered modules: 1/60
[ INFO  ] main[main] setup.go:90 building discovery config
[ INFO  ] main[main] setup.go:116 looking for 'wmi.conf' in [/etc/netdata/go.d /usr/lib/netdata/conf.d/go.d]
[ INFO  ] main[main] setup.go:123 found '/etc/netdata/go.d/wmi.conf
[ INFO  ] main[main] setup.go:128 dummy/read/watch paths: 0/1/0
[ INFO  ] discovery[manager] manager.go:90 registered discoverers: [file discovery: [file reader]]
[ INFO  ] discovery[manager] manager.go:95 instance is started
[ INFO  ] run[manager] run.go:30 instance is started
[ INFO  ] discovery[file manager] discovery.go:71 instance is started
[ INFO  ] build[manager] build.go:106 instance is started
[ INFO  ] discovery[file reader] read.go:39 instance is started
[ INFO  ] discovery[file reader] read.go:40 instance is stopped
[ DEBUG ] build[manager] build.go:153 received config group ('/etc/netdata/go.d/wmi.conf'): 0 jobs (added: 0, removed: 0)

EDIT:
I´f found I had to remove the “#” before “jobs”. Ok, thats my fault. No I can see the polling, if I run “./go.d.plugin -d -m wmi” but the Windows server is still nowhere visible.

Hey, @DE-Heizungauf5

To fix the issue uncomment # jobs:

Your config is

#jobs:
  - name: git01
     url: ...

Should be

jobs:
  - name: git01
     url: ...