Netdata Community

Access on localhost but not ip

Ubuntu 18 and fresh install of netdata

So im rather now to all this and I recently installed netdata using the installer script which all seemed to work fine, I have opened the port 19999 with ufw, and if I curl the localhost:19999 it spams all the HTML (im assuming this is the panel) but when i access it in my browser with ip and port 19999 I just get nothing. It says it is listening on every ip so I dont see why it wont connect, i found a GitHub issue (#1203) like this but i followed stuff there and nothing worked. Any help would be great thanks. Im rather new to this so some explanation would be greatly appreciated.

Hi @LostAndDead

If netdata listens on 0.0.0.0

[ilyam@pc ~]$ sudo ss -ntlp | grep netdata | grep 19999
LISTEN 0      4096         0.0.0.0:19999      0.0.0.0:*    users:(("netdata",pid=48757,fd=4))
LISTEN 0      4096            [::]:19999         [::]:*    users:(("netdata",pid=48757,fd=5))

Then it is likely your firewall configuration. Could you recheck it or show the rule?


I recently installed netdata using the installer script

Just in case, did you apply any non default configuration?

root@vps:~# ss -ntlp | grep netdata | grep 19999
LISTEN   0         128                 0.0.0.0:19999            0.0.0.0:*        users:(("netdata",pid=5692,fd=4))
LISTEN   0         128                    [::]:19999               [::]:*        users:(("netdata",pid=5692,fd=5))

And yes im an 99% sure i have the correct firewall rules, ufw allows port 19999

root@vps:~# ufw status | grep 19999
19999                      ALLOW       Anywhere
19999 (v6)                 ALLOW       Anywhere (v6)

And i ran the installer as it goes, i haven’t changing any configuration values.

Yeah, i am not familiar with ufw, but it looks like you have 19999 whitelisted :thinking:

Did you try to disable ufw temporary and see if it helps? So we can identify if that firewall problem or not.

Could there be some vps provider firewall (not your vps local fw)?

I disabled the firewall and i am now able to access it, This is odd as i already have other applications such as Pterodactyl running on the machine fine. Im going to try specifying more details with the ufw rule rather than an more general rule, ill let you know how that goes.

I setup some more specific ufw rules, specifying the protocol, origin ip and a few other things (which should have all been default) and its working now, just seems it was ufw being odd. Thanks for the help anyway, all solved now.