Netdata Community

Cannot access netdata on wsl2

I installed netdata on wsl2 Ubuntu20.04.
Then, when I visited localhost:19999, it prompted localhost rejected our connection request.
And ufw is not running.

1 Like

Hey,

This is interesting and buffling. Can you please try to curl the dashboard from inside the WSL terminal?

By default, it should just work ™️

1 Like

i noticed this too recently myself - will see if i can recreate on my end and help debug too.

looks like it installed ok

but indeed connection refused for my local netdata

note: i was able to curl to london demo just to be sure.

Could be related to this: WSL2 cannot connect to localhost when the service is running on Windows · Issue #5211 · microsoft/WSL · GitHub

I’ve had a few issues with it before.

yes
‘curl 127.0.0.1:19999’ works normally

emm
Interestingly, I just tried it again
It was found to be operating normally.
And when I posted this question, I made many attempts, such as accessing the ip of wsl, restarting wsl, and restarting the entire computer, but none of them worked.

Time will solve everything
xdddd

1 Like

So, now you can access the dashboard from a dashboard running on the windows machine or only from a curl in WSL ?

This is super interesting for us since we have a whole blog post focussing on Netdata + Windows, so we want to make sure that it’s accurate. Thanks for the info!

lol - i still cant get mine working now :slight_smile: