Added node marked as unseen


I had an existing agent installed on the cloud dashboard, it was working fine until i changed the hostname of my server. It was seen as offline. So I tried to restart the agent but it crashed.

I tried to reinstall the agent using HomeBrew and it is now running fine locally. But says it is not connected to the cloud.

I run the script to connect the agent to claim it and claimed it successfully with a minor error below:

“Found an existing netdata install managed by the system package manager, but could not determine the install type. Usually this means you installed an unsupported third-party netdata package.”

Now, i go to the netdata cloud dashboard but the node is marked as UNSEEN.

How can I resolve this issue?

Please help.

Homebrew installations aren’t officially supported by us and kickstart doesn’t officially support macOS at the moment as per Netdata platform support policy | Learn Netdata, but we’ll try to help resolve this.

In order to first try and circumvent whatever may have happened, follow the instructions at Connect Agent to Cloud | Learn Netdata to cleanly disconnect and reconnect the node. On step 4, instead of kickstart, locate on your installation and use Connect Agent to Cloud | Learn Netdata to connect the agent to the cloud.

Let us know if you still have issues after this and then we see if we can figure out what got the node in this bad state.

Thank you Christopher.

I managed to resolve it. I completely uninstalled netdata agent and reinstalled it manually using the automatic installation script.