Netdata Community

Columns in Nodes sections disappear

Hi
We have 5 war rooms with 2-6 nodes each. From time to time, randomly columns with metrics that I’ve setup disappear and I need to re-add them manually again. Sometimes when I’m adding them in one War room they disappear in another.
That’s quite frustrating each time, especially when you need to see what’s going on with the node.
Is this something I need to configure and/or is failing on our side or it’s NetData UI issue?
Thanks

Hi Victor, could you please give us some extra context to investigate this issue further?
Did you create your war rooms yourself? Have you invited your team members to these war rooms?

You also mention that some columns with metrics you’ve set up disappear. Are you referring to some charts that are on the Overview page or the Nodes pages? Or is this happening on a custom dashboard?

Hi
War rooms created by my colleague, he left the company already.
Yes, I invited other person, but no one deleted them.

Here’s the screenshot to explain what I mean - there was system.cpu, mem.available, disk.io, nginx.connections, etc columns for each node. They disappear. Next day they were back. Sometimes they are not, so I need to add them manually.

Hi Viktor,

Could give us some more information?

  1. Do you have Charts 2.0 - Beta enabled? If so, do you also get the same issue with the previous chart version?
  2. Can you tell us what columns/metrics are these?
  1. No, Charts 2.0 not enabled
  2. system.cpu, mem.available, disk.io, nginx.connections, mysql.table_locks

Hi Viktor,

Sorry for the late reply to this one. We tried to look into this and to replicate it but we weren’t successful, so please bare with me with a couple of more questions:

  • Some metrics that you mention are the default ones, system.cpu , mem.available , disk.io, when they disappear from the table to all of them these default and some that you specified disappear or just some?
  • How frequently do you see them disappear?
  • If you have more people on your team, does this happen to anyone else?
  • When this happens again can you please check the browser’s developer devtools (e.g for chrome) and see if there are any errors on the console and/or on the Network tab?

Let me know if there is any doubt and/or you need any help on any the above points.

Hi Hugo

No problem)

So answering your questions

Some metrics that you mention are the default ones, system.cpu , mem.available , disk.io , when they disappear from the table to all of them these default and some that you specified disappear or just some?

For now we are using only those default and all of them disappear

How frequently do you see them disappear?

Sometimes once per week, sometimes less frequently

If you have more people on your team, does this happen to anyone else?

Others are not using Netdata that frequently, but couple of times they reported this issue to me and I had the same.

When this happens again can you please check the browser’s developer devtools (e.g for chrome) and see if there are any errors on the console and/or on the Network tab?

Good idea. Will try.

Thanks for suggestions