Dashboard V2 is lost on my local server


I created my own local (didn’t link to netdata cloud) dashboard V2 yesterday with many graphs I need to monitor. However, when I ssh the server today, the whole customized dashboard V2 in netdata is missing and the dashboard is empty. I didn’t do anything to the server.
Question: What happened when I press the “save” button? What file is related to the locally customized dashboard V2. How can I restore my local dashboard V2?


Relevant docs you followed/actions you took to solve the issue

I have restarted the netdata program on the server, but nothing works.

Environment/Browser/Agent’s version etc

Version: v1.45.0-8-g5803c7766
Browser: Google Chrome
SSH Shell: XShell

What I expected to happen

Restore my customized dashboard V2.

hi @wqshmzh ,

I’m sorry you’ve experienced this, when at the local Agent dashboard these custom dashboards are stored on the browser’s IndexedDB under netdata-cache.

If you haven’t changed your browser, your custom dashboard should still be there.
Could you try it again, a simpler dashboard, and see it this happens as expected?

We will for sure add a callout clarifying where the dashboards are being stored.


The same happened to my local dashboard, version netdata v1.45.1. I didn’t change the browser and if I check browers’s IndexedDB/netdata/netdata-cache, key “local-custom-dashboard” and all the “cards” I created are still there but the GUI displays " Empty Dashboard".

I was having the same problem and realized it was because I wasn’t signed in. I’d totally forgotten that only the Free or Paid accounts allow custom dashboards (from my understand of the pricing page ). The UI was trying to route me there but I was getting CORS errors in the browser console. Once I worked around those, the UI threw a login screen at me & made it real obvious what the issue was.

I need something that can survive being air-gapped unfortunately, so I haven’t tested, but I’d assume that will fix it if you aren’t logged in already.

@wqshmzh @zelesepele I’m not able to reproduce this issue you’re having. (see below :point_down: )
Could you confirm which agent version you are running? I’m at v1.45.0-52-nightly


@Matt on the agent it is possible to have 1 custom dashboard but this is stored on the browser’s IndexedDB under netdata-cache .

Only on THAT browser? No way to share it?

Good to know! I’d found the dashboard data in the IndexedDB after seeing your earlier message on the thread but it just wasn’t loading up. Now I found calls to app.netdata.cloud/api/v2/accounts/me and /api/v1/telemetry/push (401 since I’m not logged in) so I’m guessing I just linked the Agent to the Cloud at some point and forgot…which might’ve locked my dashboard while I wasn’t logged in? Those CORS errors were messing with me, though, I tried capturing them in a HAR to send over but no luck.

This is probably just PEBCAK for me specifically, I haven’t done much real digging into it. Just needed something quick to monitor temperatures while I “fixed” my server’s fan controllers.

yes atm it is only on THAT browser