installed the netdata cloud agent on almalinux 8 but in netdata dash its showing ML: NOT CAPABLE

Hi @Nikhil_Darji ,

Welcome to Netdata forums and for raising this issue with us.

For us to be able to provide you with some help could you share the following details?

a) which installation method did you use?

  • native binary packages (.deb/.rpm)
  • from git
  • from source
  • docker
  • helmchart (kubernetes)
  • other

b) Provide information about your system. To get this information, execute:

# Linux
uname -a; grep -HvE "^#|URL" /etc/*release

c) Provide Netdata Agent version and build info. To get this information, execute:

netdata -W buildinfo
# If get "netdata: command not found", try (required running Netdata)
$(ps aux | grep -m1 -E -o "[a-zA-Z/]+netdata ") -W buildinfo


1 Like

Thanks for the reply @hugo
i tried the * from add node option from netdata cloud dash
here is the info

Linux 4.18.0-372.16.1.el8_6.x86_64 #1 SMP Wed Jul 13 03:56:16 EDT 2022 x86_64 x86_64 x86_64 GNU/Linux
/etc/almalinux-release:AlmaLinux release 8.6 (Sky Tiger)
/etc/centos-release:AlmaLinux release 8.6 (Sky Tiger)
/etc/os-release:VERSION=“8.6 (Sky Tiger)”
/etc/os-release:ID_LIKE=“rhel centos fedora”
/etc/os-release:PRETTY_NAME=“AlmaLinux 8.6 (Sky Tiger)”
/etc/redhat-release:AlmaLinux release 8.6 (Sky Tiger)
/etc/system-release:AlmaLinux release 8.6 (Sky Tiger)

rest command not worked

i have posted replied but it got hidden @hugo

ok, not sure if there are some security policies on the forums that could have hidden that
send it to my e-mail then,


On your case it seems netdata isn’t running, I’ve done a quick check with a different version of AlmaLinux and I get a response to netdata -W buildinfo but I also get an error trying to run service netdata start|status|stop

I don’t know what is the alternative to ensure you can put netdata running, but let me check internally

Thanks I’ve even tried reinstall multiple times but no luck

Hi @Nikhil_Darji

The libuv error you’ve posted seems weird…

Can you try please to install libuv, most likely using sudo dnf -y install libuv, then try the netdata -W buildinfo again ?