Trying to update... one install can't be updated, the other one won't start after update

I tried using the kickstart script to update my 2 netdata builds,

  • one at 1.35.1 (binpkg-deb),
  • the other is at 1.36.0-40-nightly (kickstart-build).

For the binpkg build , both the kickstart script and the package manager it says that it’s up to date.

For the kickstart-build it started to update it, and after 5 minutes, it finished “successfully”. But now the service won’t start:

Cannot read process groups configuration file ‘/etc/netdata/apps_groups.conf’. Will try ‘/usr/lib/netdata/conf.d/apps_groups.conf’
PROCFILE: Cannot open file ‘/proc/3769/status’
netdata.service: Main process exited, code=killed, status=11/SEGV
netdata.service: Failed with result ‘signal’.

What should I do? Why does netdata update is always so messy for me? :
Thanks in advance!

The main thing is not mix installation methods. Just use always and it’s unlikely you’ll have issues.

When you ran kickstart on top of binpkg-deb, kickstart should have chickened out and refuse to proceed with the installation, not say that you have the latest version. If you have kept the output, we’d love to see it. The package manager can certainly say that you have the latest version and be correct, as maintainers can take a long time to offer the latest stable. So for this node, I would just uninstall from the package manager and reinstall using kickstart.

The kickstart-build case certainly sounds very problematic. Again, we’d really need to see the output, to try and understand what happened. Regardless of what the installer did, the SEGV is very serious and we get such errors extremely rarely. You’ll have a core dump that we’d love to get our hands on and also hopefully more errors on error.log than just what you listed above. Again uninstall and clean reinstall should fix the issue, but we’d really like to understand what happened first.

You can send any sensitive info you have (including the core dump) to and I’ll make sure our engineers receive it.

1 Like

Regarding the first issue: What distribution and release of that distribution are you using?

If you’re not seeing any version of Netdata newer than 1.35.0, then it’s likely that it’s a platform we no longer officially support with native packages, in which case you can get the latest version either by updating to a supported platform (see our platform support document for info on what we currently support), or by performing a clean reinstall and passing --static-only to the kickstart script (the need for the --static-only option in this case is a known issue that we intend to eventually fix, but have not had the time to work on yet).

1 Like

Thanks, then I won’t reinstall it until you find the underlying issue. I sent you the error.log, let me know if you need anything else.

Yes, it’s Stretch, that’s why it doesn’t get newer updates.

Updating the node would be a bit of a hassle, so I tried clean reinstalling with static-only flag:

wget -O /tmp/ && sh /tmp/ --reinstall-clean --static-only

It resulted in successful installation based on the last few lines of the install… but now it says that

root@build:~# netdata -v
-bash: netdata: command not found

Hi @Tudvari

Since it’s a static install, it’s path has changed (we install static builds under /opt/netdata) Can you check that path?

1 Like

Thanks, yes it is there and it’s working, already claimed it. Thanks again! :slight_smile: