unknown file format: '/etc/netdata/go.d/x509check.conf

Suggested template:

Problem/Question

Relevant docs you followed/actions you took to solve the issue

Environment/Browser/Agent’s version etc

What I expected to happen

Could you elaborate a little bit more? Really we want to help you with your issue but we can’t understand your problem.

@Tasos_Katsoulas1 Thanks for your response.

I am working on setting up certificate monitoring, the jobs have been setup correctly according to the x509.conf file in my etc/netdata directory as guided by the documentation.

Problem is I cannot find a monitor showing the certificate stats and when I try to troubleshoot using the netdata user and ./go.d.plugin -d -m x509check i get the error below:

[ INFO ] main[main] agent.go:110 using config: enabled ‘true’, default_run ‘true’, max_procs ‘0’
[ INFO ] main[main] setup.go:67 loading modules
[ INFO ] main[main] setup.go:86 enabled/registered modules: 1/65
[ INFO ] main[main] setup.go:91 building discovery config
[ INFO ] main[main] setup.go:121 looking for ‘x509check.conf’ in [/etc/netdata/go.d /usr/lib/netdata/conf.d/go.d]
[ INFO ] main[main] setup.go:137 found '/etc/netdata/go.d/x509check.conf
[ INFO ] main[main] setup.go:142 dummy/read/watch paths: 0/1/0
[ INFO ] discovery[manager] manager.go:90 registered discoverers: [file discovery: [file reader]]
[ INFO ] discovery[manager] manager.go:95 instance is started
[ INFO ] run[manager] run.go:30 instance is started
[ INFO ] build[manager] build.go:106 instance is started
[ INFO ] discovery[file manager] discovery.go:71 instance is started
[ INFO ] discovery[file reader] read.go:39 instance is started
[ WARN ] discovery[file reader] read.go:63 parse ‘/etc/netdata/go.d/x509check.conf’: unknown file format: '/etc/netdata/go.d/x509check.conf’
[ INFO ] discovery[file reader] read.go:40 instance is stopped
[ DEBUG ] run[manager] run.go:41 tick 0
[ DEBUG ] run[manager] run.go:41 tick 1

Hope it is a little bit more detailed.

Thanks,

Sam.

Ok, thanks for the detailed summary, could you share your config (hide sensitive information)? Best guess a misaligned line or a tab instead of spaces in the config file (yamlish files are sensitive to those)

[minor] did you use the edit-config script right?

Tasos.

@Tasos_Katsoulas no tabs were used in the config file just the deletion of the # signs to activate the jobs.

Ok I would love to see that config because there are many things that may have gone wrong

Just two more things to take into consideration:

IMPORTANT:

  • Parameter ‘name’ is mandatory.
  • Jobs with the same name are mutually exclusive. Only one of them will be allowed running at any time.
  1. You comment in the “jobs” section in the end of the config file, right?

@Tasos_Katsoulas I will work on that and provide feedback.